It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This is a recent issue. The game used to work without problem with the mouse. I start the game and a screen appears stating that a gamepad was detected and to press a mouse button if I want to use the mouse instead. Two issues here:
1. There is no gamepad connected to the pc
2. Pressing the mouse button does nothing. I'm stuck on that screen, can't click on anything and must use ctrl-alt-del to get out of the game.

Anyone having a similar issue?


Update: Problem Solved

I found out it was detecting an other device, a Thrustmaster steering wheel and saw it as a gamepad. I did try all buttons on on the Thrustmaster with no reaction in the game but its only when I disconnected it completely that the problem was solved. Funny thing is that this steering wheel was connected before without any issue with the game. I assume this happened after a recent Win10-64 update. Anyway, problem solved.
Post edited August 28, 2020 by procyoniv
No posts in this topic were marked as the solution yet. If you can help, add your reply