It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Greetings gentlemen,

While looking for a possible unofficial patch on the net, I came across the following site:


The said site is full of interesting informations about the game.

And to my delight, I discovered an official quest editor that unless I am sadly mistaken, was not added with the GOG release:


-> Taken from their "download" section: [url=][/url]

There is also a tutorial available here:


However, be advised that I just installed the program, launched it and took a quick look of what options were available. I have yet to fully test it but I encountered no problems so far.

I hope that it can be of use to the GOG community.

EDIT: I also managed to find an official "quest module" called "Journey In Uma" from the following site:


Direct download Link:

Post edited May 21, 2012 by elonoic
This site has a large base of custom quests for Darkstone:

They also have a nice package full of skins
I cannot get the Darkstone Quest Editor to work for my GOG version of Darkstone on Windows 10, 64bit. I've tried all compatibility modes, and have even tried to force windowed mode. It starts with a loading bar then disappears. If I check Task Manager, it shows a 32bit installer program, but there's no way to access it. If anybody knows of a workaround, please let me know. I'm considering running it in a legacy Windows virtual machine, which is pretty ridiculous all things considered, with the GOG version of the game already working fine.