It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm just wondering if anyone has had success in being able to assign a controller when playing Cuphead through a Steam Link. For I've tried a Steam controller, a wired Xbox controller and a PS4 controller, each to no avail.

While some controller buttons work on the Steam and Xbox controllers, they're still unusable, and the PS4 controller doesn't get a response at all (ie, won't even get you past the Cuphead start screen). The actual button within Cuphead to assign a controller is disabled (ie, a lighter shade of red).

I appreciate the game has only just been released, such that it may be something that needs to be patched, but as I say, I'm just curious to know if others have encountered a similar problem and/or found a workaround.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Assuming you got the game from GOG (very safe assumption if you are posting here), you need to add the game to Steam as a non-steam game ("Games" menu, "Add a Non-Steam Game to My Library"). Very straightforward, unless you installed the game through GOG Galaxy. Games which use Galaxy features tend to set a Start menu shortcut that launch the game through Galaxy, and this really doesn't work well with Steam Link streaming. Just make sure the Steam shortcut points directly to Cuphead.exe, and you should be fine.

After that, launch the game on the Steam Link through the Steam Big Picture interface.

I tried this and the game worked perfectly fine with a PS4 controller paried to the Steam Link. The Steam Controller may need to be remapped for the game, since non-Steam shortcuts default to desktop mappings.