It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have this game on Steam and Origin, but today bought the GOG version, since it has all patches, 64-bit mode bundled and no DRM. Sadly I had the issue with Galaxy client, but I had other major issue: only stereo sound! Both Steam and Origin versions give me 5.1 surround sound. To be honest I don't know the GOG version had this problem only - I will check the steam/Origin versions.

EDIT: I just checked the Steam version, it has 5.1 sound.
Post edited May 13, 2017 by OptimusHun
No posts in this topic were marked as the solution yet. If you can help, add your reply
I've 5.1 sound on the on-board sound chip(ALC892) + Creative P5800. I've just configured my speakers in Windows for 5.1 output.
The original release had 5.1 sound and as far as I know this one has it too.
Maybe you can set it manually in the config (Crysis has lots of tweaker you can do manually).
I cant get 5.1 in crysis either, any fix.
I've done (graphics) tweaks for 10 years now in Crysis, I'm pretty sure this sound problem can also be solved with a custom configuration. I haven't tried it myself yet because it's already working for me with the in-game settings. But the solution below should theoretically work.

Lookup the installation folder of Crysis (where CrysisLauncher.exe is located, not one of the bin folders). Make a new text file in notepad and save it as autoexec.cfg (you need to change "save as" to "All filetypes".
Place/save the new autoexec.cfg in the Crysis folder you just located.

We're going to add a few commands / tweaks into the just created configuration file. You can copy past the commands between the horizontal lines below (don't copy the lines).

---

; User Options commands
con_restricted = 0
r_displayinfo = 0

; Sound
s_SoundEnable = 1
s_SpeakerConfig = 5

---

con_restricted disables the use of advanced commands (default), by setting it to zero you disable this restriction.

r_displayinfo show additional (debug) information during the game. We want to disable this so we set it to 0.

s_SoundEnable Enables sounds. It's probably not required to include this command but since you're having sound related issue's it might be worth a shot. So we set it to 1. (It should work perfectly without this command.)

s_SpeakerConfig has 8 possible values. It tells the game to use a specific speaker setup. This is the command where it's all about. Because most people use a 5.1 speaker configuration I've set it to 5 but other values are possible too.
0 = Default system setting
1 = Mono
2 = Stereo
3 = Headphones
4 = 4.1
5 = 5.1
6 = Prologic
7 = 7.1

If the above solution doesn't work rename the autoexec.cfg to system.cfg (some commands only work in a system.cfg instead of a autoexec.cfg).

There's a lot you can do with tweaks in such a file.
There are many configurations that alter graphics and such. If you want to tweak more I would recommend reading guides like this one: http://www.tweakguides.com/Crysis_1.html .

Over the years I've created a collection of great tweaks and commands. If anyone's interested let me know. :)
Post edited May 28, 2017 by Blinkin89
Thx for the info, i just connected my hdmi to my av amp and it now works, but have saved that link, cheers
Aah that's great to hear. Enjoy! :D
avatar
Blinkin89: I've done (graphics) tweaks for 10 years now in Crysis, I'm pretty sure this sound problem can also be solved with a custom configuration. I haven't tried it myself yet because it's already working for me with the in-game settings. But the solution below should theoretically work.

Lookup the installation folder of Crysis (where CrysisLauncher.exe is located, not one of the bin folders). Make a new text file in notepad and save it as autoexec.cfg (you need to change "save as" to "All filetypes".
Place/save the new autoexec.cfg in the Crysis folder you just located.

We're going to add a few commands / tweaks into the just created configuration file. You can copy past the commands between the horizontal lines below (don't copy the lines).

---

; User Options commands
con_restricted = 0
r_displayinfo = 0

; Sound
s_SoundEnable = 1
s_SpeakerConfig = 5

---

con_restricted disables the use of advanced commands (default), by setting it to zero you disable this restriction.

r_displayinfo show additional (debug) information during the game. We want to disable this so we set it to 0.

s_SoundEnable Enables sounds. It's probably not required to include this command but since you're having sound related issue's it might be worth a shot. So we set it to 1. (It should work perfectly without this command.)

s_SpeakerConfig has 8 possible values. It tells the game to use a specific speaker setup. This is the command where it's all about. Because most people use a 5.1 speaker configuration I've set it to 5 but other values are possible too.
0 = Default system setting
1 = Mono
2 = Stereo
3 = Headphones
4 = 4.1
5 = 5.1
6 = Prologic
7 = 7.1

If the above solution doesn't work rename the autoexec.cfg to system.cfg (some commands only work in a system.cfg instead of a autoexec.cfg).

There's a lot you can do with tweaks in such a file.
There are many configurations that alter graphics and such. If you want to tweak more I would recommend reading guides like this one: http://www.tweakguides.com/Crysis_1.html .

Over the years I've created a collection of great tweaks and commands. If anyone's interested let me know. :)
Well, I've installed Crysis 1 recently and since I tweak pretty much every game before even playing it then I went through forementioned tweakguides guide ( before seeing this post :P ).
I would like to add that there should b no spacebars in commands. So it shouldn't be like " con_restricted = 0 " just " con_restricted=0 ". Also forementioned tweak guide mentions that system,cfg contains the commands to b executed on GAME-ENGINE STARTUP and the autoexec.cfg contatins those to b executed AFTER game-engine loads. If I would hv some sound issue then I would place all ur commands in both files just to b sure that game doesn't skip anything.
Sounds like some good additions, thanks. :D
Spaces haven't caused problems for me, but I'll look into it.
I know this is a bit of an old thread, but I came across this whilst googling the problem.
Unfortunately I haven't been able to fix the problem entirely, but I have found that the 32 bit version has full 5.1 sound although it seems to offer much worse performance on my PC. (GTX 1070 and i7 3770K @4.5ghz, 8GB 1600mhz RAM)

If I do find a solution I'[ll be back to update my post, but for now it seems that it's broken in some way.