It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
The problem is, after I finish the third mission, the game loads the first two movies, but won't load the "Echo Base" clip.

The game ran flawlessly up to this point.

I've tried disabling movies in the crusader.cfg (still won't load the rebel base), downsizing them and reinstalling. It still doesn't work.

Here's a video I've found where it does load:

http://www.youtube.com/watch?v=d48YBaTYHEo#t=4m55s

Here's a save game (the quick save) if someone can check it out (back your saves up first) - http://www.megaupload.com/?d=T5GNDQOU
Post edited June 29, 2011 by FraX
No posts in this topic were marked as the solution yet. If you can help, add your reply
Replayed the level, avoiding the freight elevator. Same bug. I can press F1 and peruse those 2 pages, I can see the interface after this, and, if I drop the weapons, the ammo, not the weapons themselves appear on the black screen. I can turn the aiming reticule on/off, I get the confirmation message. I can also "exit to DOS" by pressing ctrl + x, but I can't access the save menu or anything else.

Maybe I should have avoided the conveyor belts?

This is getting tedious, especially since I'm playing on No Remorse difficulty.
Post edited June 29, 2011 by FraX
Same thing here on that save, i think it might've gone corrupt.;(
Do You have any earlier saves to check them?

Damn, i've never played that level in a way, to get this bug.;/
Post edited June 29, 2011 by Arteveld
Thanks for posting and trying.

Okay, the solution is to avoid the conveyor belts (you have to use one though).

First time going in I took the conveyor belt path, but was unable to use it entirely, due to the fact I missed the red keycard (you have to jump on a freaking hover pad). I proceeded down the freight elevator (which is much harder, since there are 3 enemies on screen waiting for you once you arrive and a mech production line you have to stop).

Second time in I used every single conveyor belt (even got to the secret room filled with the explosive barrels and 6-8 chests). Ended up with having the opportunity to collect 2 RP-22's and 2 GL-303's.

Third and final run through, I avoided every conveyor belt except the one you have to use the box to climb on an elevator pad and I tried my best not to stay too long on the moving tracks. Missed a few GL-303 clips and the RP-22, plus a bunch of clips, but I figure actually being able to finish the level was better.

To see if you have this bug, the elevator that is partially surrounded by the green slime should move in a peculiar way. Probably all elevators too, but this one is particularly glitchy (you can drop in the slime just by walking on it).
Good to know, i don't even remember how i used to finish this level. Even if i did, i use so many savegames, i've probably just loaded an earlier one, and did something in a different way. My post originally had a link where someone mentioned a buggy conveyor belt, but didn't know which, so i scrapped that link. I know, that sucks.
Anyhow, You'll probably get the guns later. Go get 'em!;)
avatar
FraX: Thanks for posting and trying.

Okay, the solution is to avoid the conveyor belts (you have to use one though).

(...).
Hey, are you 'Frolsa84' on YouTube? You've replied to my comment under a video about the game. If this is indeed the scenario causing it, then my hats off to you, sir, for figuring this out!

Rather odd, though, that whether the video loads is dependent on how you deal with the conveyor belts.

So am I correct in assuming that following the third scenario you've described doesn't result in the lockup? And do you know if there's a way you can get the clips you mentioned without the game crashing?
The sprite glitches and you can't teleport properly, hence why the video doesn't play (it just results in a black screen in which you can press F1 and drop weapons, etc., but nothing else).

The clips/weapons you can get on this mission are really, really unimportant. I've had more than enough throughout the game on No Remorse difficulty.

Yeah, try to avoid the conveyor belts, or alternatively don't save/load while you're on them (easier said than done on No Remorse and it's just conjecture on my part).
Post edited December 17, 2011 by FraX
I've been plagued by bugs as well on mission 3.
First there were 4 teleporter pads that would work but the screen would remain centered on the pad itself with only way out by quitting the game. Similar problem with huge elevator in other room. And at the very end - mission 4 won't load.
Is there a code to warp into map 6 - Echo Base after mission 3?
P.S. Does anyone know which particular conveyer belt screws things up? Or is it several?

UPDATE: I've spent 2 days browsing several forums, getting diffrent versions of the game, installing it on several diffrent machines and trying to replay Mission 3 again and again....
And gues what - I DID IT!!!!!!
I skipped the main secret and used cargo elevator to reach Level 2, avoiding almost all conveyor belts that I could - and I'm in the Echo Base with savegame to share - skill level Loose Canon. PM me for savegame (game version 1.21) if interested.
Post edited December 31, 2011 by Sithicus
Okay, heres how to fix this without restarting the level (which is basically hell, considering Crusader is one of the hardest DOS PC games ever).

1: Go to the game directory (i.e, c:\Games\Crusader) wherever you have your game downloaded
2: Open up the 'dosboxCRUSADER_single' file
3: Locate the 'CRUSADER.EXE' text
4: Add ' -warp 4' to that line (don't forget the space between the .EXE and -warp 4 command)
5: Start the game, it should warp you straight to level 4, but you'll have NO weapons.
6: Type 'JASSICA16' whilst playing the game and then hit F10. This will cheat you in all the wepons. If you want to play fair, you can press CTRL+D to drop the weapons you didn't have, but it's up to you.

After that, save the game over the save slot you were using for Level 3 and close the game. Then, re-loacate the 'dosboxCRUSADER_single' file and remove the ' -warp 4' command from the end of the CRUSADER.EXE text line.

This SHOULD fix it, it fixed it for me, thank god, because I was about to delete the game and request a refund from GOG, and I couldn't see another way to fix it (replayed the mission again, which did nothing, same thing occurred).