It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I went and dug up the discs I had my old store breeds on and tried installing them to my GoG version of Creatures Exodus and I installed the Creatures Remastered patch beforehand. But it still says it can't detect the games. I have them installed through GoG Galaxy, is that they problem? I'm in the mood to play this old game and I want to play with as many breeds as I own and I can't seem to find help anywhere so I would appreciate any advice..
West_Winds: ...
Welcome back to playing Creatures! The Remastered Patch is designed to fix this problem, so it's odd that it's not fixing things up. A couple of quick questions:

- When using GOG Galaxy, does it still install the game to your hard drive? (Silly question... I haven't tried it out myself, though!)
- Did you install the Remastered Patch before or after the main installation?
- What operating system are you using?
- Which breed packs are you trying to install, and are you using the .exe files?

I have a couple of thoughts on why it might not be working, and hopefully you'll be able to use them again very soon!
They install under Program files/Galaxyclient/games/

After the main installation.

I'm using windows 7 Professional

So far I've only tried installing my Astros and my Hardmans but I have them all. And I'm doing it from install exes
West_Winds: ...
I know that installing under Program Files can create a slight issue: I've always installed under My Documents, which the Remastered Patch can locate right away. The free breeds (like the Astro Norns) are still available from Gameware. But you probably have the latest version! Still, you can find them all here. If possible, I would recommend installing under My Documents, running the Remastered Patch, and then trying to install one of the breeds. Hopefully that works for you: Good luck!
I tired re-installing the regular download outside of the galaxy client and now the breed installers recognize c3 but not docking station as installed. What's worse is that now Docking station doesn't see C3 as installed. >.< This is so frustrating.
West_Winds: ...
I can understand your frustration! I had to reinstall a few times when I was working out exactly how to get it to work. Silly question, but did you clear out every file before reinstalling? The game tends to act strangely even if something is leftover. You'll usually find the files split up after installation, usually in the following spots:

- Program Files (If you didn't install to My Documents, which is recommended)
- My Documents\Creatures\Creatures Exodus
- My Documents\Creatures\Creatures 3
- My Documents\Creatures\Docking Station

Do you have a screenshot or the exact text of the errors you're seeing? One other thing is where you're running the game from: If you boot up Docking Station, it will default to loading from installblast.exe. Did you by any chance run the update from the message that pops up? This can break the game because it's really not supposed to be there. You should change the game load location to run from engine.exe to avoid that issue. And finally, did you run the Remastered Patch again after reinstalling? I forgot to do this at one point: Just throwing it out there as another possibility! You might get a little more information in this topic. Sorry that it's giving you all these problems! Hopefully everything will be resolved soon.