It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game could not be started due to a direct draw error.

Windows NT/2000 5.1 build 2600 (Service Pack 3)
OriginalDisplay DirectX (no modules)

Below that the error records the username.

This is running C3 (Exodus) in windowed mode with 16-bit color on the latest NVidia drivers on Windows 7 64-bit. This appears to be a DirectX problem but I have yet to run into a user with this specific issue.

I had picked up Exodus in the hopes of avoiding the finagling with the display settings and avoiding the CPU speedups when hacking/jerryrigging the original C3/DS but it appears to have not been the case.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Did you by any chance download the latest update for DS that you might have been alerted to? I know this sometimes causes startup issues, but the fix is rather easy! I'm still not certain if this will help you, though I've searched for a solution, and haven't seen anyone with this particular issue, as you said. It's never fun being the only one! Try the following, which was suggested at Creatures Caves:

Grendel Man said: To do this, right-click on your desktop shortcut/main menu link/whatever and select "properties." Underneath "target," you'll see a file path - it should read something along the lines of "X:\Program Files\Docking Station\InstallBlast.exe." Change "InstallBlast.exe" to "engine.exe" (without quotations, of course).
I am having this problem too, exactly, and would very very VERY much like to know what the solution is. I have tried quite a few things now, and I keep getting a 'direct draw' error, as the first post states it.

The suggestion posted here is no help at all, nor does anywhere else seem to have any clues into how to fix this. All I wanted was to relive my 'mad scientist' days with this game. T_T And it feels like there's just this one little piece stopping me from playing.

My Dock Station portion is working alright, but Creatures 3 refuses to open under any circumstances, with this same error message each and every time. I've even tried digging up old versions of DirectX, though I'm not entirely sure that's the fix. (My file path started with engine.exe, instead of InstallBlast.exe)

Help us,
Post edited June 27, 2015 by Teh_Lord_Coley
I was hoping to get some more information from the original poster to keep helping out with the process. I had a feeling that my original idea wasn't the right solution, so it's good to finally have that confirmed! The odd thing is that no one seems to have posted a solution to this issue, even though it's not all too rare. Here are a couple of ideas. Hopefully you can get back to your mad scientist days again soon!

- Have you tried creating a docked world within Docking Station? This combines Creatures 3 with Docking Station. Just want to see if this can start up for you, as a check to see if the game can properly load C3 files.

- Did you try running the game as an administrator? This sometimes works for other problems, possibly with the compatibility settings set to Windows 2000.

- Where is the game installed to? Installing under My Documents is often recommended, although I'm not sure if this will help in this case. You might trying uninstalling and reinstalling under My Documents.

- Have you installed any add-ons, and/or the remastered patch?

It's an odd problem, and it's a shame that no one has posted a solution for it anywhere. If you get any other error messages, feel free to post away! There are some other ones that might have better solutions available. Good luck!
I believe I'm having the same error.

Windows 10
Lenovo Y50-70
Intel HD 4600
GeForce 860M