It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So Cossacks Back to War will start, I can get to the menu, but when I start any sort of mission/tutorial/game the screen renders completely, the music plays, my mouse can move, but the game is "stuck" and will not respond to any keyboard or mouse input.
I tried the cs-dd-patch, tried setting the affinity, am starting the game directly with the dmcr.exe executable, tried changing game speed to slow, set various compatibility modes (xp sp2, xp sp3, win95) and nothing seems to work.

Any thoughts/advice?
I am using win 7 64 bit with no problems so you can exclude the OS as the culprit. Most likely, it is related to the drivers. Which graphics card and driver do you use?
Running an ATI R7 200 series, with Catalyst version 14.9 drivers.
I also have an ATI FX 8120 8 core processor, which maybe is contributing?
Looks like I have same problem with the first two Cossacks as well, none of the three behave any differently.
Well I upgraded my drivers to my vid card and the problem seems to have resolved itself with the latest version of ATI drivers. Awesome!
Same issue, but with Geforce GTX 650. Interesting that I ran Cossacks in May this year (2015) and they worked perfectly.

Currently updating drivers in the hopes that it would work. Will post an update once done.

Updated drivers and problem went away,
Post edited November 21, 2015 by KBA3AP