It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

How do I limit the whole game to the 17th century? I've tried setting 18th century to : "never" but they still build their 18th century buildings during peace time.
Post edited September 06, 2013 by Soccorro