It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I am unable to play any game from cossacks anthology, on my computer.
I am able to run the game, use main meny, etc., but when i am trying to play any game it freezes after loanding, the music still plays, i am able to move the mouse cursor, however i can't click anything, the screen is frozen, just after the game started.
I tried changig resolution ( tried all ), tried runnig via compatibility modes. On the internet i found that my problem is quite rare, and nobody solve it as most issues comes with frozen mouse cursor. I also tried playing the game using my nVidia graphic card manually, although it's used as preffered card.

Asus F555L
System: Windows 8.1 64-bit
Processor - Intel i7-5500 2.4 GHz
8 Gb RAM
Graphic card: Nvidia GeForce 940M, Intel (R) HD graphics 5500
No posts in this topic were marked as the solution yet. If you can help, add your reply
do you have 'cs-dd-patch.exe' run this to extract 'ddraw.dll' copy 'ddraw.dll' to the root dir of back to war or other version and then RENAME it to MDRAW,DLL this fixes the frozen mouse!!! mdraw.dll
avatar
stevenlisa0: do you have 'cs-dd-patch.exe' run this to extract 'ddraw.dll' copy 'ddraw.dll' to the root dir of back to war or other version and then RENAME it to MDRAW,DLL this fixes the frozen mouse!!! mdraw.dll
Just to point out, I'm having the same problem, but this did NOT fix anything. In fact, I could move the mouse before renaming ddraw.dll to mdraw.dll, but after doing that, I still get the map freeze AND mouse freeze.

I have much the same specs except I'm running Windows 7 rather than 8.
Same problem here, does someone has fund the solution ?
Same problem when running under Wine.

Putting an old ddraw.dll into game directory and replacing mdraw.dll allows for one animation frame, but then the game freezes too.
Try solution from the topic: Cossacks - European Wars (Editing configuration file manual)
I actually bought the GOG one specifically to cure this very problem. I already had the game.
This issue is rather odd in that my system is completely different than the others, and much older. I keep an older computer or two around so that I don't have to deal with this nonsense ordinarily. Windows seems to be incompatible with itself.

Anyway, same problem. Game freezes when you start. It is definitely some kind of animation issue. I noticed the flags in the setup menu for a game blink on for an instant then disappear instead of waving as they are supposed to do.

I tried running as admin. I tried changing the resolution to 1024x768(in windows). I looked for the mode file...there wasn't one for the expansion. There is another file but it is unaffected by changes you make in the options menu. I tried explicitly changing all the settings and then changing them back. I tried running in compatibility mode for windows 98, XP. I am actually running a near period machine:


Dell Inspiron 1520
Core 2 Duo T5450 1.66 GHZ
2GB ram
Windows Vista
Mobile Intel 965 Express Chipset with shared video ram (display adapter)

I ran DX 10 install for x86. Nothing...it just freezes. Music plays; mouse moves; nothing else happens. Just frozen peasants and some music.
I am going to try to disable windows explorer and load it without explorer to see if maybe that works? But this problem seems to affect several people and on completely different systems...
Oddly enough, I tried this on my alienware M14X with windows 7 and it works perfectly. I've never had that happen before! Older software working better on a newer operating system than the older?

The only thing I can figure is that on my older laptop I did turn off a ton of services and stuff in MSCONFIG to make the machine run faster...since it is so old. I matched the safe mode with network support and turned on COM+ and the sound, and a few other things like .NET framework and JAVA support...maybe it is to do with that? Why no other games?

Did any of you do something similar on your machines?
Okay, update! I got this fixed. On the machine above. A day after I get this game working on my newer machine, the thing died. Now this is my only working computer so i had to get cossacks working.

Anyway, Following my reasoning from the last post, I ran MSCONFIG.
I looked for items that maybe I shouldn't have turned off in there...

I turned on a few items that were turned off in services. I am not sure which one of the three actually did the job, but chances are you'll know because it is turned off.

So go to:

(start) > Run -> MSCONFIG > services >

Turn on:
Application layer gateway services
Base filtering engine
Background intelligent transfer

Then Apply OK to exit, then restart computer.

Cossacks should now be fully working!