It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello everyone,

I'm trying to run Cossacks on a computer with Windows 10.

The game seems to start normally but when entering the game, it's stuck. I can see the initial screen with a small patch of territory and peasants, but it's completely stuck and I can only do Alt + F4. Another "issue" is that when I'm on the screen where you decide teams, map, etc, the flags are flickering and downright completely disappearing.

Any thoughts? I set the compatibility to Windows XP, both SP2 and SP3, set lower resolutions, still nothing.

I also pasted the ddraw.dll file in the game directory but it seems to have no effect whatsoever.

Thanks in advance.
Starting with Windows 8 DirectPlay API was dropped by Microsoft and replaced with some emulator that causes mouse lag and possibly other problems.

I switched back to windows 7 for this and other reasons and I intend to keep it for a while.

You can try running dmcr.exe directly and see if it will help.
Post edited December 29, 2015 by pisces72
I have a similar problem. Cossacks won't play on Windows 10, nor will American Conquest.
Hi,

you guys might try Aqrit's ddwrapper.
Fixed my mouse cursor issues.
Cannot post the Link in here, but google will find it.
Just copy the .dll & .cfg file from the .zip file, into your game root directory and start configuring with the .cfg file.


Best,
Kampfcobra
I have Windows 10 pro and Cossacks : Back to War gave me the 0xc0000022 error.So i did some digging and here is the solution i've found.

Go to Settings/Apps/Apps & features/Programs and Features/Turn Windows features on or off/Legacy Components/DirectPlay - if it is checked off check it on,if it is checked off your problem is not like mine so you should seek a different solution.

I hope i've helped :3
avatar
Screamshield: I have Windows 10 pro and Cossacks : Back to War gave me the 0xc0000022 error.So i did some digging and here is the solution i've found.

Go to Settings/Apps/Apps & features/Programs and Features/Turn Windows features on or off/Legacy Components/DirectPlay - if it is checked off check it on,if it is checked off your problem is not like mine so you should seek a different solution.

I hope i've helped :3
Just wanted to reply and say thank you very much as your solution worked by checking DirectPlay in Legacy Components. I did it with European Wars and I'm sure it will be the same for the others. Have a great day.
avatar
Screamshield:
I've tried looking under the Apps & features section and can't seem to find the Programs and Features section. Is it only certain W10 versions?
avatar
Screamshield:
avatar
ShadowWulfe: I've tried looking under the Apps & features section and can't seem to find the Programs and Features section. Is it only certain W10 versions?
On your keyboard there should be a button with the symbol of windows. Press it + R, the run window will appear. Type 'control panel' in it and press OK. The control panel window will open, now look for 'programs and features' and open it. Top left you should see 'Turn windows features on or off'. Click on it and look for legacy components/features. I hope this helps.
avatar
Screamshield:
Thanks! I was able to figure it out that way.