It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Used to have steam pirated version because there's no demo, good game so I bought this on GOG. Now I see that this game runs much slower that steam version, I use standard quality for my 1080p monitor on both versions.
Don't know if this is something on my side or it's just GOG version is locked like on 30fps, somebody have slower game too or it's only me?
1. Good point in this that I can do perfect every day and rush hours have max 3 clients in row instead of 4 cause I can do everything much faster.
2. Bad point because it's like a cheating playing in slow mode, there's no challenge anymore.
Don't know what to think about this.
avatar
Cziczaki: Used to have steam pirated version because there's no demo, good game so I bought this on GOG. Now I see that this game runs much slower that steam version, I use standard quality for my 1080p monitor on both versions.
Don't know if this is something on my side or it's just GOG version is locked like on 30fps, somebody have slower game too or it's only me?
1. Good point in this that I can do perfect every day and rush hours have max 3 clients in row instead of 4 cause I can do everything much faster.
2. Bad point because it's like a cheating playing in slow mode, there's no challenge anymore.
Don't know what to think about this.
I appreciate you buying the game, it means a lot. :)

So as far as the slowdown goes, this is the PC/Windows version correct?
Yes, PC Windows 10 version.
This game runs slow all the time during menu too, even autosave takes more time than Steam version.
At the beginning it's make this game borin, later, I quess at harder receipts it will help a lot. So don't know did I should enjoy this or not.
Launched Fraps to record at what speed I play, it shows in corner that I have only 22 FPS, but when I press F9 to record movie, game speed up to 30 FPS like steam version.
WEIRD
Of course it doen't mean that I have 30FPS now, still 22FPS with Perfect every day.
I have found on reddit that C,S,D!2 also have this bug and it's something with game engine, but didn't find any fix.
Have you tried lowering the graphics options to Low, or lowering the resolution of the game?
Tried, still this same.
One bug that seems to happen with a few people is that the game defaults to an integrated graphics card instead of using a proper graphics card. Can you see if that is what could be causing the issue?
How to change this?
avatar
Cziczaki: How to change this?
Here you go: https://www.techadvisor.co.uk/how-to/pc-components/how-set-default-graphics-card-3612668/
I have AMD processor and grapchic card and tried what I can and brother who know more about computers found that it looks like I don't have any integrated grapchic card, also usage of my AMD R9 is higher when i play this game so it looks like it use AMD card as "default".
I had this problem too. It was fixed when I changed the intel graphics card power management setting to high performence.
Now it's running at 30 frames, at normal speed (Used to be slowly at 21 frames).

ps. I'm playing on my laptop. I tryed forcing the game run with nv card before adjusting power management ,didn't work.

edit: turns out setting to high porformance didn't solve slow-motion problem.
What worked was opening the graphic card page. Having other games running in background can make csd's speed and fps get back to normal, too.

edit 2: I think I've found out my problem. When I disabled "speaker", in "sound" settngs, the game returns to 30 frames.
Another way of dealing with this is turning on anything that make sounds, eg. a music player, that will, too, get the game to normal speed (30 fps).
Some screenshots: uses gog's fps counter (bottom right)
Attachments:
Post edited March 14, 2018 by cloud1084
avatar
cloud1084: I had this problem too. It was fixed when I changed the intel graphics card power management setting to high performence.
Now it's running at 30 frames, at normal speed (Used to be slowly at 21 frames).

ps. I'm playing on my laptop. I tryed forcing the game run with nv card before adjusting power management ,didn't work.

edit: turns out setting to high porformance didn't solve slow-motion problem.
What worked was opening the graphic card page. Having other games running in background can make csd's speed and fps get back to normal, too.

edit 2: I think I've found out my problem. When I disabled "speaker", in "sound" settngs, the game returns to 30 frames.
Another way of dealing with this is turning on anything that make sounds, eg. a music player, that will, too, get the game to normal speed (30 fps).
Some screenshots: uses gog's fps counter (bottom right)
I seem to be having the same problem, only with 25 FPS instead of 22.