It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The horizontal (left-right) is fine.
But the vertical is out of wack. Even at the lowest setting the slightest movement makes me look straight to the sky or the ground. This makes the game unplayable.

Source of the problem: Too high fps, in my case several 1000 in training mission.

Solution: Nvidia Profile Inspector, select "Conflict: Desert Storm", check whether you have the right one since that game is listed twice, and set the Frame Rate Limiter to 60 and set Limiter Mode to "V2 Allow all". 120 works better for me since it reduces the input lag a bit.
And while we are there: Set Anti-Aliasing to 4x4 supersamplig.

Side note: This game can run in 3840x2160 natively. in my case (Nvidia):
HKEY_CURRENT_USER\SOFTWARE\Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Pivotal Games\Conflict Desert Storm\Device Settings
ResolutionIndex=23 (Hex 17)
This also fixes the Aspect Ratio. You may have to use a different value on your system.

If GOG could fix that issues directly it would be "special GOG, they can do it".
Post edited October 10, 2020 by Jou_de
In my testing, this game seems to be hardcoded to ~30 ticks per second. I.e. unless you cap the framerate to 30 FPS, audio will desync, scripted cutscene animations will play out incorrectly, and in-game AI will misbehave.

The game would probably need to be hacked to run at a faster internal timer in order to resolve these issues.
Post edited October 16, 2020 by KingSyphilis