It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

just installed CC2, it starts but cant get past the splash screen. Sometimes I get the starry night splash. one time I got as far as the start menu only to have it crash out. Most times all I see is a black screen with the game pointer which will respond to the mouse but then after while the screen goes blank.

I have tries re-installing serveral times, running as adminstrator. I have tried setting compatability to windows 95, I have tried lowering the running resolution to VGA and reducing colours to 256. Nothing seems to help. Any ideas?

PS CC1 runs without issues!


Similar issue. I installed the game on my Microsoft Surface Book and get Black Screens. I have to alt-tab to exit the program and when I do I get a split second glimpse of what should be the game menu and mouse cursor, then my desktop. I have tried different resolution settings in regedit and compatibility modes with no success =/

Edit: I wonder if there was a windowed mode we could get around this problem, but so far I can't find any info on a windowed mode setting.
Post edited September 20, 2019 by Dasmart88
I don't know what the issue is for you guys but I can at least confirm that it works for me with the latest Windows 10 64-bit fully patched (v1903 Build 18362.356) and Nvidia Geforce driver 431.60 with a GeForce GTX 1070.

I'm running the game on a 3440x1440 monitor with the game resolution set (via Regedit) to 1366x768. Scaling is done by my display.

The only compatibility setting I use is to run as administrator.