}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Same problem here with occasional crashes.

"Save campaign" feature doesn't help with lost progress because game crashes before creating save.
Has anyone worked with GOG support to see if they have a fix for this problem?
Well, I'm having to eat humble pie because I now have CC2 working under Windows 10 64-bit, but I'm not exactly sure why. By working I mean that in a campaign game, clicking on Continue no longer causes the game to crash. I've only tested it through two or three missions in the game but so far absolutely no crashes whereas before it would always crash.

So, what has changed. Well, I was on Windows 10 64-bit version 1703 and found that Windows update had been trying every day for over a month to upgrade me to 1709 (the Fall Creators Update), but kept failing (after re-downloading the upgrade every single time!!!!!). When I became aware of this issue I discovered that the error code was 0x8007001f - a rather generic code that gave me no real clue to what the problem was. I tried every "fix" I could find on the internet regarding this (and there is much snake oil online regarding fixes for this error code) but to no avail. I eventually found a clue to my problem here : http://www.zdnet.com/article/dont-move-your-windows-user-profiles-folder-to-another-drive/.

Like many people, my desktop has a relatively small SSD drive (C:) which I use for the operating system and program files and a HDD (D:) for everything else. Using guidance from websites like this, https://www.tenforums.com/tutorials/1964-move-users-folder-location-windows-10-a.html (Method One), I had used sysprep during my last Windows 10 install to move all of my user profiles to my HDD. I believe it was this that prevented the 1703 to 1709 upgrade from working.

So, I bit the bullet and decided to do a clean install of Windows 10 64-bit 1709 but using a Microsoft supported method of moving most of my user profile to my HDD (e.g. http://www.dummies.com/computers/operating-systems/windows-10/how-to-change-the-location-of-user-folders-in-windows-10/).

After two days of installing everything that I had previously installed on my PC (including the same video card driver version), I got round to reinstalling Close Combat 2. And this time when playing CC2 it no longer crashes. Interestingly, the ONLY compatibility setting that I have turned on is to run the program as an Administrator (without which the game cannot save progress). It doesn't even need to be set to Windows XP mode or the like.

The only other change I made was to update my BIOS but I seriously doubt that made a difference here.

So was CC2 crashing between missions because of the version of Windows 10 (1703 vs. 1709), or the fact that I had used sysprep to move my entire user profile to my D: drive, or that my BIOS was 6 months out of date, or that my Windows 10 install had become corrupted somewhere? I really don't know the answer, but I suspect using sysprep to move my entire user profile was a major contributor to it.

Anyway, thought I'd post my experience here in case it helps someone else.

BTW - there's some excellent general advice on the Matrix forums by zakblood with regard to getting Close Combat working on Windows 10 (starts here : http://www.matrixgames.com/forums/fb.asp?m=4415444).

One other thing, make sure that when you install CC2 that you run the setup program "as an Administrator".
Post edited March 22, 2018 by ikrananka
Or is the solution simply to ensure that you install the game by running the setup program "as an Administrator"? This is one other difference between my current install of the game and the one before I reinstalled Windows.

Would be great to hear back from someone who would be willing to uninstall the game, use CCleaner on the registry, reboot and reinstall the game "as an Administrator".
I am doubting that these GOG Close Combat releases need to be run as administrator. The originals certainly do as they are making modifications to files in the directory C:\Program Files (x86). Since Windows 7 that directory has default restrictions added so regular users cannot make changes. This is why the game and Config Managers need admin rights.

These GOG games are being installed to C:\GOG Games where you will not need admin privileges to make modifications to files or directories.

I have noticed with the GOG CC5 version that some registry entries are not correct. This make be due to them creating the installer from scratch. So CC2 could be missing some important registry entries as well.
Thanks mooxe, I forgot about the install directory differences.

I still wonder why though that with my retail version it crashed in the same way that GOG users have been experiencing, but now after a new install of Windows 10 it's working fine.
Anymore news on this front?
I'm running the game on 2 Win10 machines and so far the only issue is Alt - Tab crash, and the need to hack the resolution from the registry on one machine to make it work. I will try to install the software to another location and clean the registry to try to reproduce the CTD.
Look at this post, for a possible solution:
https://www.gog.com/forum/close_combat_series/program_has_stopped_working_error_cc2/post4

3 Windows 10 machines updated to the last OS updates were not working with the game installed in a path different than the GOG default, installing the game there solved the issue
Post edited April 21, 2018 by Andrea1988
Unfortunately hasn't helped. WIn10 updated and CC2 installed to default directory yet still crashing
I've made the following:
- Uninstalled CC2
- Removed CC2 registry keys with regedit (I think that this is the most important step)
- Installed to GOG Games folder in C: drive

Try it and let me know