}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
As soon as I launch I crash to desktop?
Tried restarting after install.
Also tried holding 'control' to disable opening video.
No effect so far, anyone else having this probem?

Running Win7
Attachments:
Post edited February 07, 2018 by Bezzer1985
avatar
Bezzer1985: As soon as I launch I crash to desktop?
Tried restarting after install.
Also tried holding 'control' to disable opening video.
No effect so far, anyone else having this probem?

Running Win7
Did you try running it in compability mode? Like executing the program in XP x Pack compability?

Right click on the shortcut on your desktop, choose properties, choose compability.
Post edited February 07, 2018 by MaGo72
avatar
Bezzer1985: As soon as I launch I crash to desktop?
Tried restarting after install.
Also tried holding 'control' to disable opening video.
No effect so far, anyone else having this probem?

Running Win7
avatar
MaGo72: Did you try running it in compability mode? Like executing the program in XP x Pack compability?

Right click on the shortcut on your desktop, choose properties, choose compability.
Yep, tried running CC2 in various compatability modes and as adminstrator without result.
Game launches, video starts to play (music can be heard) but then crash.
I'll try to help, although I only have the retail boxed version. But it is working fine for me under Windows 10 and it also worked fine for me under Windows 7 (both 64-bit).

1. First, please check which version is installed by the GOG installer. Go to the installation folder, right click on the cc2.exe file and select Properties. Then look on the Details tab and under "Product Version" what does it say? The final version that Microsoft released is 2.0b and that hopefully is what GOG is selling.

2. It sounds like display settings may be causing a problem so let's try manually setting the game resolution. What is the native resolution of your monitor? Mine is 3440x1440, but I find the game looks best when set to a lower resolution. I set it to 1024x768. You can do this once the game has started, but seeing as you can't even get to that point this will instead involve editing the Registry. So only do this if you're comfortable doing this, and also make sure that you back up the registry beforehand. Start RegEdit and search for the Close Combat game settings. The retail Microsoft location is here : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft Games\Close Combat\2.00

Set "ScreenX" to a value of 1024 and "ScreenY" to a value of 768.

You might also want to change the "Launched" setting from 0 to 1. I believe this forces the game to automatically skip the intro videos which may bypass your issue.

3. Also, it is necessary to run the game in compatibility mode, mine is set to "Windows XP (Service Pack 3)". It is NOT necessary to run the program as an administrator or to select any of the other compatibility settings.
Attachments:
cc_reg.png (70 Kb)
Post edited February 07, 2018 by ikrananka
avatar
Bezzer1985: As soon as I launch I crash to desktop?
Tried restarting after install.
Also tried holding 'control' to disable opening video.
No effect so far, anyone else having this probem?

Running Win7
Try to change your screen resolution
avatar
ikrananka: I'll try to help, although I only have the retail boxed version. But it is working fine for me under Windows 10 and it also worked fine for me under Windows 7 (both 64-bit).

1. First, please check which version is installed by the GOG installer. Go to the installation folder, right click on the cc2.exe file and select Properties. Then look on the Details tab and under "Product Version" what does it say? The final version that Microsoft released is 2.0b and that hopefully is what GOG is selling.

2. It sounds like display settings may be causing a problem so let's try manually setting the game resolution. What is the native resolution of your monitor? Mine is 3440x1440, but I find the game looks best when set to a lower resolution. I set it to 1024x768. You can do this once the game has started, but seeing as you can't even get to that point this will instead involve editing the Registry. So only do this if you're comfortable doing this, and also make sure that you back up the registry beforehand. Start RegEdit and search for the Close Combat game settings. The retail Microsoft location is here : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft Games\Close Combat\2.00

Set "ScreenX" to a value of 1024 and "ScreenY" to a value of 768.

You might also want to change the "Launched" setting from 0 to 1. I believe this forces the game to automatically skip the intro videos which may bypass your issue.

3. Also, it is necessary to run the game in compatibility mode, mine is set to "Windows XP (Service Pack 3)". It is NOT necessary to run the program as an administrator or to select any of the other compatibility settings.
Hey, I tried what you have suggested without joy.
I can confirm the version is correct and I was running in compatability mode as described.
I can set the game to skip the videos without launching but this had no effect.
I tried adjusting the resolution to 1024 & 860 as described and edited the registry again no change still the same crash.
avatar
Bezzer1985: I tried adjusting the resolution to 1024 & 860 as described and edited the registry again no change still the same crash.
Did you mean 1024 x 768 or did you do 1024 x 860? It should be the former.

If the above suggestions don't work then all I can suggest is that you contact GOG technical support.
I am receiving the same issue as the Bezzer1985. None of these fixes worked for me either.

The EXE for CC2 is automatically set for compability to Windows NT 4.0 Service Pack 5 with no option of changing it.

EDIT:

OK - This seems to be 'a' workaround. I don't know why this even works, but if you run any other game you have, alt-tab out of it (while keeping it open), and then launch CC2 for some reason the game will launch. Of course doing this may hog up your processes depending on what other game you launched.
Post edited February 09, 2018 by thehawkness
avatar
thehawkness: I am receiving the same issue as the Bezzer1985. None of these fixes worked for me either.

The EXE for CC2 is automatically set for compability to Windows NT 4.0 Service Pack 5 with no option of changing it.

EDIT:

OK - This seems to be 'a' workaround. I don't know why this even works, but if you run any other game you have, alt-tab out of it (while keeping it open), and then launch CC2 for some reason the game will launch. Of course doing this may hog up your processes depending on what other game you launched.
OK, yep I have no idea why but that worked fine!
I assume that launching DOSBOX does something with the display settings, which mean when you launch CC2 its already 'correct' which doesnt cause the error. How random! I launched Theme Hospital, alt-tabbed and CC2 launched no trouble.
avatar
Bezzer1985: I assume that launching DOSBOX does something with the display settings....
But CC2 is a Windows 95 game and doesn't use DOSBOX. Anyway, that's a weird solution. Have you tried manually changing your desktop resolution to 1024x768 and then starting the game? Does that work?
avatar
Bezzer1985: I assume that launching DOSBOX does something with the display settings....
avatar
ikrananka: But CC2 is a Windows 95 game and doesn't use DOSBOX. Anyway, that's a weird solution. Have you tried manually changing your desktop resolution to 1024x768 and then starting the game? Does that work?
Yep, no effect.
Strangely this workaround allows it to launch even if I am on 1920 my native resolution.
avatar
ikrananka: But CC2 is a Windows 95 game and doesn't use DOSBOX. Anyway, that's a weird solution. Have you tried manually changing your desktop resolution to 1024x768 and then starting the game? Does that work?
avatar
Bezzer1985: Yep, no effect.
Strangely this workaround allows it to launch even if I am on 1920 my native resolution.
Bizarre. Certainly one for GOG technical support.
avatar
thehawkness: I am receiving the same issue as the Bezzer1985. None of these fixes worked for me either.

The EXE for CC2 is automatically set for compability to Windows NT 4.0 Service Pack 5 with no option of changing it.

EDIT:

OK - This seems to be 'a' workaround. I don't know why this even works, but if you run any other game you have, alt-tab out of it (while keeping it open), and then launch CC2 for some reason the game will launch. Of course doing this may hog up your processes depending on what other game you launched.
Just FYI, if you get a cheap laptop with Windows XP you can play a lot of these old games with no problem. I have one and is very handy to have.
avatar
thehawkness: OK - This seems to be 'a' workaround. I don't know why this even works, but if you run any other game you have, alt-tab out of it (while keeping it open), and then launch CC2 for some reason the game will launch. Of course doing this may hog up your processes depending on what other game you launched.
Strange! that works for me too, after the same initial error. I was happily remembering how to play this thing when in the second mission of the campaign it bailed to my desktop. I had to go to task manager to kill it as it wouldn't respond :/

A pity, I was looking forward to playing this again. I hope there's a proper fix for these things.