It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I don't give much of a fudge about the Steam overlay, but someone mentioned it in a thread about 3Dfx and how they use DirectX only because 3Dfx does not allow the overlay. Well in my hunt for better frame rates my solution also fixed the 3Dfx/overlay problem.

3Dfx is far superior to DirectX in certain older games because those games were made during a time when 3Dfx/Glide and OpenGL ruled the roost instead of DirectX, in Clive Barker's Undying 3Dfx massively improves lighting, shadows and the general atmosphere of the game. Sadly 3Dfx also suffers intermittent fps drops due to ancient shoddy coding.

What I did was replace the nGlide 1.00 included with Undying with version 1.04 from the nGlide website. You can just download the latest version of nGlide, install it and that may or may not solve the problem, but it will also make the nGlide configurator a global install so if you need it for more than 1 game and using different settings for each game you won't be able to. So here's how to make it local to Undying (and any other game using nGlide)...

1.) Download and install nGlide (but don't close the installer), it will place 9 files in a system folder and 3 shortcuts in the start menu

2.) After install and with the installer still open, click on 'Show Details' to see which folder the 9 files went in to

3.) Navigate to that folder with the three 3Dfx files, three glide files and the nglide_config.exe (there will also be the readme.txt and the uninstaller)

4.) Copy those first 7 files to GOG Games/Clive Barker's Undying/System (or whatever path you chose), you can rename the 7 files that they will replace if you want to undo these steps later

5.) Close the nGlide installer, uninstall nGlide from Programs to remove the remaining two files and the three start menu shortcuts

6.) Run the nglide_config.exe to tinker with 3Dfx settings then enjoy Undying as it should look, but with a better frame rate and working Steam/Fraps/Raptr overlays

Post edited May 28, 2015 by krashd
Thanks for this 3Dfx workaround, krashd! The game looks so much better using 3Dfx than it looks on DirectX, but I opted to play it using the latter because of the dreaded frame rate inconsistency; I'd rather have a more smooth game with worse graphics than a slightly better look that suffers on the game play side of things, but Undying has such superior atmosphere when you use nGlide that it always saddened me a bit to sacrifice it.

I'll try this right away and update the thread to let you know whether it worked for me or not.

Again, thank you so much!

[EDIT] As for the overlays, I couldn't care less, as I don't use Steam or any of the other programs/clients.
Post edited April 09, 2015 by groze
Works great. But there is no 32bit-mode available in the graphic options unfortunately...
Post edited May 22, 2015 by Wolfram_von_Thal
This thread is now obsolete, as v1.04 of nGlide now ships with the installer.
krashd: ...replace the nGlide 1.00 included with Undying...
krashd: This thread is now obsolete, as v1.04 of nGlide now ships with the installer.
I did an account refresh and then downloaded the GOG Undying installer.
As of 2016 June 08, the nGlide version shipped/included with/in GOG Undying installer is 1.00

So I think the information in this thread is still applicable.

Later edit:
oh, now I figured that you were probably talking about steam Undying installer?
sorry for confusion
Post edited June 08, 2016 by mobutu
Just to make things clear, as of 2016 June 17, the nGlide version included with the GOG Undying installer has been updated to v1.04. The game runs very smooth 60+ FPS.
I really don't care about Glide because I always preferred D3D but I have no idea how to enable the Steam Overlay for this game. Any ideas?