It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi All!

Are there any tricks / tips to start the game under Windows 10?
The compatibility mode does not work

Thanks & Best regards
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have the same issue, I have tried installing Direct X 9 but it didn't work.

Apparently there are no issues with the Steam version but I really don't feel like paying 10 EUR for I game I have already bought, twice now.
I had a similar problem, the game appeared for a while in the process list and died.
For me, the problem has been solved by changing the monitor refresh rate to 60hz.

if your monitor / laptop / drivers does not support such frequency, I recommend:
https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU

PS. Reboot the computer after adding and the new resolution can be selected from the advanced display settings:
https://www.addictivetips.com/windows-tips/how-to-add-a-custom-screen-resolution-in-windows-10/
Post edited May 13, 2019 by wyrwijajec
I was having the same problem on window 8.1 - installing DX9 fixed it. Which was surprising, as I coulda sworn I already had it installed for lots of other old games I run...
Yeah, I'm having the same issue. I've got a pretty new laptop with Windows 10 OS. At first, I installed the Steam version of the game. I ran into issues there. Initially, I received an error dialog stating "Unable to find Steam." I googled that problem, and learned that other users had to copy the Steam.dll file from their Program Files (x86) folder into the CivCity: Rome subfolder within the Steam files. I did that. After that, whenever I tried to launch the game in Steam, the "Play" button would change to "Running" for a few seconds then die and go back to "Play". And the game never launched.

I heard about GOG.com, so I decided to try installing CivCity: Rome via GOG Galaxy. It installed, but then when I went to launch the game, I experienced the latter issue (see above) again with GOG. The game wouldn't launch.

I'm frustrated and disappointed. But I'll try to change my monitor's refresh rate like wyrwijajec suggested...

UPDATE: I went into Settings > System > Display > Advanced display settings > Display adapter properties for Display 1 > Monitor, which brought me to the menu in the attached image. I found the drop down options to change the screen refresh rate, but for my device, it seems that 144Hz is the default and the ONLY setting available...
Attachments:
Post edited February 20, 2021 by indielinguist