It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Dear developer thank you for not forgetting Linux users. Sadly the currently provided 32bit as well as 64bit binaries in version 1.8.2 both require GLIBC_2.33 which is too new for the current stable Debian 11 which has only 2.31 available. Please consider providing a version built against an older GLIBC.
avatar
Adventurers: Dear developer thank you for not forgetting Linux users. Sadly the currently provided 32bit as well as 64bit binaries in version 1.8.2 both require GLIBC_2.33 which is too new for the current stable Debian 11 which has only 2.31 available. Please consider providing a version built against an older GLIBC.
Hey,

Indeed, it requires GLIBC_2.33, it is quite new, released back in february 2021.
Regarding getting on Debian 11, you can add the testing repository mirror in order to get them.
This is the official package tracker for debian and glibc specifically:
https://tracker.debian.org/pkg/glibc

You need to add it to the sources.list for your computer as following:
sudo echo "" >> /etc/apt/sources.list
sudo echo "deb http://ftp.debian.org/debian// testing main contrib non-free" >> /etc/apt/sources.list
sudo echo "" >> /etc/apt/sources.list
sudo echo "deb-src http://ftp.debian.org/debian/ testing main contrib non-free" >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get install libc6

I also suggest you to lower the priority of the testing mirror ( https://wiki.debian.org/AptConfiguration ).

I think the libc6 2.33 (glibc 2.33) should be available in the coming months for debian stable.
Cheers
Post edited June 14, 2022 by binogure
avatar
Adventurers: Dear developer thank you for not forgetting Linux users. Sadly the currently provided 32bit as well as 64bit binaries in version 1.8.2 both require GLIBC_2.33 which is too new for the current stable Debian 11 which has only 2.31 available. Please consider providing a version built against an older GLIBC.
avatar
binogure: Hey,

Indeed, it requires GLIBC_2.33, it is quite new, released back in february 2021.
Regarding getting on Debian 11, you can add the testing repository mirror in order to get them.
This is the official package tracker for debian and glibc specifically:
https://tracker.debian.org/pkg/glibc

You need to add it to the sources.list for your computer as following:
sudo echo "" >> /etc/apt/sources.list
sudo echo "deb http://ftp.debian.org/debian// testing main contrib non-free" >> /etc/apt/sources.list
sudo echo "" >> /etc/apt/sources.list
sudo echo "deb-src http://ftp.debian.org/debian/ testing main contrib non-free" >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get install libc6

I also suggest you to lower the priority of the testing mirror ( https://wiki.debian.org/AptConfiguration ).

I think the libc6 2.33 (glibc 2.33) should be available in the coming months for debian stable.
Cheers
Many thanks for the detailed answer. I will consider it but normally I am a little bit hesitant to update basic system libraries because of dependency hell and in favor of a stable system. ;-)
Maybe I will try schroot.
Hey,

Lately I've been working on improving stability on Linux. So the v1.10.0, that comes out today, will use an older version of GLIBC. So it should now work OOTB for you right now!

Cheers
Xavier
avatar
binogure: Hey,

Lately I've been working on improving stability on Linux. So the v1.10.0, that comes out today, will use an older version of GLIBC. So it should now work OOTB for you right now!

Cheers
Xavier
Many thanks for your feedback. I can confirm the new version is now working on Debian 11 (Bullseye).