It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

As the title suggests, this only works for Nvidia cards.
If you have an AMD or Intel card and know an alternative for the steps listed in point 2, feel free to post it.

I tried many, many things to get the game to work on Win10 and I ended up with the below settings.
With any other configuration, the game instantly crashed after the intro movie or the interface just froze.

1) Set Compatibility Mode to:
- Windows 7,
- Disable Fullscreen Optimizations,
- Run this program as an administrator.

2) In Nvidia Control Panel go to "Display" -> "Adjust desktop size and position" and:
- Select "Aspect ratio",
- Set "GPU" for the "Perform Scaling on" option,
- Check in the "Override the scaling mode set by games and programs" option.

Optionally, you can add the game to "Manage 3D settings" -> "Program Settings" and play around with the stuffs there.
I turned on Vsync there and switched off it in the game (had some weird - but not game breaking - flickering sometimes on the menu interface with the built-in one) and also added FSAA, so the game looks a bit better.

Additionally, if you have problems with the game settings menu, you can change the screen resolution in the ../Documents/Tilted Mill/Children of the Nile/CotN.ini file too (example: Game Window Height 1080 Game Window Width 1920). Just make sure that you back it up, before you edit it.

After setting up the above stuffs, I played quite a while and didn't found any major issues with the game (some minor ones: cast shadows are a bit off center and the river water has some little flickering sometimes near the shore).
But keep in mind, crashes still can happen and a future Windows patch may will stop the game to work for good.


Specs: Win10 Home v1803 Build 17134.472, GF GTX 1050Ti 4GB, 8GB RAM, i5-2400 3.1GHz
Post edited December 25, 2018 by Yrion735