It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I bought this game recently after the steam version turned out to be broken.

When I first tried to run the game it crashed to desktop after the loading screen. Running in compatibility mode for XP SP 2 seemed to fix this.

However, when I tried to go into the settings menu to change the resolution the game would either freeze up immediately and have to be force-closed, or would show the settings menu and immediately stop responding the moment I tried to click anything.

After messing with the .ini file a bit the problem persisted, but eventually fixed itself magically somehow, and was now in widescreen.

With the game now working and in the proper resolution, I played around for a while and everything was fine. I downloaded the Horus Overhaul Texture Pack and things worked normally.

Problems only started up again when I noticed that the labourer hauling animation was missing. I thought that the file might have been accidentally deleted or overwritten or something, so I used verify installation to re-download it. This promptly caused the game to stop working again. This time when I loaded up the save the fps seemed pegged at an unplayably low frame rate. It made no difference whether I hit pause or play, it would not go above a certain level. I assume it's a refresh rate issue.

I have been unable to fix this, and in trying I have noticed that the issue of freezing whenever I go into the settings menu has come back. No fix of any kind that I can find online works.

I am using a Windows 8 PC, my monitor is 2560x1440, 60hz refresh rate.

The game is broken in its default state. I don't want to sound whiny or something, but I paid a relatively small but not insubstantial amount of money for this game and I would kind of expect it to at least function properly. Does anyone have any suggestions for what I can do to fix this problem? Thanks.
No posts in this topic were marked as the solution yet. If you can help, add your reply