It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I bought this since I remember it from long ago.
But I cannot play. It crashes as soon as I try to start a scenario (menu and intro works) /just a "Children og the Nile stopped working2 windows pop op.
I tried compatability mode but this just makes the menu unresponsive.
I tried the Direct X - but no luck :-(

I cannot find out if I should try the unofficial patch on GOG version or not
Post edited February 04, 2018 by Aastrup
Same here, game crashes on any scenario and on third/last tutorial.

Tried compatibility mode, running as an administrator, reinstalling, updating my nvidia drivers, etc. It keeps crashing.
Same thing :(, can't play the game at all on windows 10.
I have the exact same problem.

It crashes when I try to launch (or load) a scenario.

It used to work, but it doesn't any longer. :(

Has anyone come up with a solution for this problem yet?
I run it in vista sp2 mode and lowered the resolution from 1080p to 720p and it worked. (1920x1080 to 1600x900)

With this fix below I can run it in windows 10 in 1080p.

Here is the link to the file. This fixed the crash issue I had with windows 10 and 1080p. \o/
Post edited June 08, 2019 by Greymantle1_TTV
I use Windows 7, x64. The above post for fixing issues with Windows 10 seems to have worked for me also. I downloaded the "" file, which contained a modified CotN.exe, and swapped it out for the original one. I also set compatibility mode to Vista sp2 and I checked run as administrator for good measure.