It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Been doing the city of Waset in the Grand Campaign, and everything was going pretty well. On Pharaoh number 4, pyramid built, most of the win conditions met, just need the last Mastaba for for the tenth townhouse to bolster itself up to a large estate. Then the labourers stopped hauling materials across the river for projects. The barges and landings were all there, and there had been no issue before, just all the sudden it stopped working. I destroyed and rebuilt all my landings, and that seems to have worked, however one landing will not be rebuilt because the bricklayer keeps getting stuck right next to it, and ALL the people in the city have suddenly begun to walk at about half the speed they did before. I have no idea why, but it is impacting the city's functionality. The last estate refuses to upgrade still as well, and frequently doesn't seem to get any food from the harvests.
BluePaladin, this all sounds very weird, nothing I've ever seen happen. So, maybe a corrupt game save? I have had that happen a few times, if I saved and worked on too quick. Try picking up an earlier save and try again.

This with people walking slower will happen if you (inadvertently or on purpose) take down the speed of the game, but that will have no effect on anything else.
Post edited March 27, 2019 by Jytte
Reloading an older save seems to have fixed the speed issue. The issue with statues persisted somewhat. Rebuilding the landings seemed to get them going. Oddly, importing statues didn't do anything, even if they were delivered on the right side of the river.

Oddly, however, on completion of the mission, it skipped the second intermediate period set, and went straight to the New Kingdom.
Hmm... It seems that CotN can behave 'oddly' at times on some computers. Remember, this game was made 15 years ago, and most of us are now on Win 10, which apparently for some is an issue.
If the campaign won't run the scenarios in sequence, just pick them up and play individually, they are all available as stand-alone scenarios. I don't even know why the 'grand campaign' is there, as it's just repeating those same scenarios, and I never played them as campaign.
Post edited March 30, 2019 by Jytte