It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Summary: the screen remains black from start, except showing mouse cursor, intro movie sounds and then later menu background music plays. There's nothing clickable "hidden" in the black, so the main menu is not there at all, not just missing gfx output. Previous version of game on the same system works well.

I posted also directly to game forum, with few more details.

http://www.forum.chaos-reborn.com/viewtopic.php?f=7&t=5785
This question / problem has been solved by RafiRomeroimage
Not exactly the same issue I had, but recent Chaos Reborn gave me a nasty garbled graphic screen (used to work fine). I found that switching to windowed mode (rather than full-screen) fixed it. I then tricked my window manager into making it look exactly like full-screen mode, so everything is fine again.

To switch manually, edit ~/.config/unity3d/Snapshot\ Games\ Inc_/Chaos\ Reborn/prefs and change the only option with Fullscreen in the name from 1 to 0.

Note that a recent update also changed the character in the above dir name after Inc from . to _ for some reason.

I guess they updated the Unity3D engine recently*, causing such breakage, although the change log doesn't seem to say as much.

recently = since the last time I tested, which may have been over a year ago...
There is some discussion over here, and some people found workarounds for their problems (I'm running it without problems, so I can't be a ton of help):
http://steamcommunity.com/app/319050/discussions/0/1470841715957277597/

& yes, the game engine was updated from Unity 4.x to Unity 5.6.0.
So, I was waiting whether some next update either of Chaos or glibc will fix this issue, and it never happened.

Today out of curiosity I tried to check the forums and stuff, and reread quickly what kind of workarounds are suggested, one thing catch my eye, it did look like the game may work in windowed mode.

I tried that by manually editing "~/.config/unity3d/Snapshot\ Games\ Inc_/Chaos\ Reborn/prefs" file to switch fullscreen to 0, and I had to put window size values there (and initially I didn't notice height is ahead of width, so I got 1080x1920 window :D ). = this works, but I prefer to play in fullscreen.

As I'm using KDE5, I decided to convert the window into fake fullscreen, so I set in the prefs file the window size 1920x1080 (LCD resolution), then I went into "Special Window Settings" (in window menu, Alt+F3 by default in KDE), and set it up to "fullscreen, force, yes" (position&size tab) and "no title bar, force, yes" (appearance tab).

This works for me, now I have fullscreen Chaos with latest version, although it looks like it eats maybe a bit more resources than native fullscreen of Unity3D engine.
The last patch 1.13.2 will still show only black screen when switched to fullscreen.

My workaround of using full screen window should be still valid (didn't try yet, will post here if it will not work, otherwise take it as working workaround).

But overall this is quite unfortunate, so there's no fresher version of unity or some more robust way of initialization, to make this work? :/ Been two patches since the problem was introduced.
I'm probably too late to the party, but a quicker and easier workaround is to just run the binary files for the game (ChaosRebornLinux.x86, or ChaosRebornLinux.x86_64) with the "-show-screen-selector" parameter.

This forces the typical Unity launcher window to appear, and in it you should select your preferred resolution and tick the "Windowed" option underneath. Despite that, the game will start in fullscreen mode and it will show everything on screen. (In case it does launch on windowed mode, you can simply switch to fullscreen mode with the in-game options).


PS: Better still, in order to avoid typing the "-show-screen-selector" parameter, you can edit the start.sh launcher script and substitute the line:
execute_game "${bin32_name}" "${bin64_name}" "${bin_path32}" "${bin_path64}" "${lib_path32}" "${lib_path64}"
with:
execute_game_with_params "${bin32_name}" "${bin64_name}" "${bin_path32}" "${bin_path64}" "${lib_path32}" "${lib_path64}" "-show-screen-selector"
If you're comfy with stuff like that, you may have some luck forcing the resolution/ full-screen mode via the commandline:

-popupwindow Create the window as a a pop-up window, without a frame.
-screen-fullscreen Override the default full-screen state. This must be 0 or 1.
-screen-height Override the default screen height. This must be an integer from a supported resolution.
-screen-width Override the default screen width. This must be an integer from a supported resolution.
-screen-quality Override the default screen quality. Example usage would be: /path/to/myGame -screen-quality Beautiful

https://docs.unity3d.com/Manual/CommandLineArguments.html

If true fullscreen is a problem, a popupwindow with full resolution is visually the same.
avatar
RafiRomero: If you're comfy with stuff like that, you may have some luck forcing the resolution/ full-screen mode via the commandline:

-popupwindow Create the window as a a pop-up window, without a frame.
-screen-fullscreen Override the default full-screen state. This must be 0 or 1.
-screen-height Override the default screen height. This must be an integer from a supported resolution.
-screen-width Override the default screen width. This must be an integer from a supported resolution.
-screen-quality Override the default screen quality. Example usage would be: /path/to/myGame -screen-quality Beautiful

https://docs.unity3d.com/Manual/CommandLineArguments.html

If true fullscreen is a problem, a popupwindow with full resolution is visually the same.
I'm comfy with command line, but there's a catch. If you use bundled "start.sh" from GOG, i.e. "./start.sh -popupwindow", the argument is not delegated to the game, and it starts again with black screen + mouse cursor.

I simply edited my own "my_start.sh" with trivial content "game/ChaosRebornLinux.x86_64 -screen-fullscreen 0 -popupwindow -screen-width 1920 -screen-height 1080" and this works for me, it starts the game visible.

So the conclusion is:

* the latest version on GOG as of today (Patch 1.13.3 16 August 2018) is still unable to correctly switch to full screen on my machine

* you can use command line options, when you avoid the GOG starting script (makes me wonder what good is it for then, and why they can't make one with argument support) ... (and why there is 32 bit version included in the... oh wait, this is not 64b deb package from repository... it's so weird+cumbersome to install/update/stay-aware anything without the package manager ... anyway I wonder who's using still 32b OS now after like 15 years of 64b availability)

This workaround should make the game run, if you have the same issue (not similar, like corrupted graphics, but same one = black screen with cursor mouse only), and I guess this is pretty much final state for the foreseeable future.

(as a SW (and ex-game-dev) programmer I'm sort of curious what's so wrong about Unity vs libc that they can't fix it on engine side, but whatever...)

Anyway, thank you for all the support and advice. :)