It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

First time I visited Vendrick's domain I went out of sequence exploring and once I got all 22 sphere orbs nothing unlocked.

I tried again with 2 new save files and nothing popped. I got the Moon Seeker achievement across 2 saves and then got "Star Seeker".

I tried twice going in the intended checkpoint order in Vendrick's domain just to make sure it wasn't linked to "sequence-breaking" the game, nothing.

When I went back to my main and grabbed the last star I needed there I got "Star Collector" for owning every single orb, but still no "Orb Seeker".

Am I gonna have to nuke the game from my HD, reinstall it and replay from scratch from a brand new save again?

Anyone encountered this?

I asked on Steam as well but I doubt I'll get an answer.
Post edited November 20, 2023 by Megacyclo
No posts in this topic were marked as the solution yet. If you can help, add your reply
Bumping thought I have no illusions.

I reinstalled the game and started a new save file again, trying again to collect the 22 orbs while following the sequence of the cutscenes and nothing happened again.

Anyone encountered that problem? I find it annoying I cannot 100% the game due to some dumb glitch.