It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I recently got Carmageddon 1 & 2, haven't tried the sequel yet but in the original game with nglide I only get 20-40 fps (first level), and that's with some settings turned down. With the Win 95 patch I get a somewhat stable 40-45 fps (first level) but the graphics is not as good. Is this normal? I have a i7 920 running at 3 GHz and a GTX 580.

I've tried to download and use DgVoodoo 2 glide wrapper but when I change the glide2x.dll file and start the game I only get a black screen, sound works however and I can hear the game running.
Carmageddon 3dfx on an emulator is notoriously slow unless you have a very powerful cpu.
As for the Win95 version, did you use the -highres in the commandline? As it will run in a higher resolution then and looks better.
I don't know if the Dosbox version GOG uses is compatible with dgVoodoo, if not try Ykwong's or Gulikoza's builds, I don't know if you will get better performance though.

Carmageddon 2 should run fine as it's a native Win9x application, at least on my system it runs without issues.
Carmageddon 1 I run with the Win95 patch as the Dosbox emulated versions are too slow for me (AMD 2.5GHz).
Post edited June 23, 2014 by Strijkbout
Thanks Strijkbout. I did not know about -highres. I have to try it next time I play. I can also add that when using nglide I lose a lot of fps whenever I go into cockpit, about 20 fps loss according to fraps. However there is no loss when using the win95 version.
Post edited June 23, 2014 by Citronvand
avatar
Strijkbout: Carmageddon 3dfx on an emulator is notoriously slow unless you have a very powerful cpu.
As for the Win95 version, did you use the -highres in the commandline? As it will run in a higher resolution then and looks better.
I don't know if the Dosbox version GOG uses is compatible with dgVoodoo, if not try Ykwong's or Gulikoza's builds, I don't know if you will get better performance though.

Carmageddon 2 should run fine as it's a native Win9x application, at least on my system it runs without issues.
Carmageddon 1 I run with the Win95 patch as the Dosbox emulated versions are too slow for me (AMD 2.5GHz).
Is the commanline thing possible to do in Windows 8.1? If so, how? I'm normally a Mac user so I'm no Windows expert and I'm having similar resolution issues.
avatar
coffeegator:
You should edit the shortcut to something like "c:\gog games\carmageddon\carma95.exe" -highres (note that I typed -highres outside the quotes).
avatar
coffeegator:
avatar
Strijkbout: You should edit the shortcut to something like "c:\gog games\carmageddon\carma95.exe" -highres (note that I typed -highres outside the quotes).
I tried this and either it doesn't do anything or the difference is too small to be noticeable. I'm not sure which.
avatar
coffeegator:
The maximum resolution Carmageddon supported is 640x480 which is low by todays standards but it should be a big improvement from the lowres 320x200.
Maybe you need to edit the ddraw.ini to set the width= and height= lines to higher settings.
avatar
coffeegator:
avatar
Strijkbout: The maximum resolution Carmageddon supported is 640x480 which is low by todays standards but it should be a big improvement from the lowres 320x200.
Maybe you need to edit the ddraw.ini to set the width= and height= lines to higher settings.
Still no visible difference, but maybe my game was already running at the higher resolution for all I know. I think I need to see some good screenshots to make a comparison and be sure.
Isn't the command -hires, not -highres?
avatar
Aridoom: Isn't the command -hires, not -highres?
Exactly, by default in windows patch, base game will start always with this mode for most people but Splat Pack must be told to do so.

Reason behind this is probably change in files for expansion or something else.

You can change additional settings for win executable in ddraw.ini even opengl or linear filtering. Filtering set to sharp and gdi enabled can help with less blurred look but tend to pixelated view without -hires.
Post edited July 01, 2014 by HenitoKisou
avatar
Aridoom: Isn't the command -hires, not -highres?
Yes you're right, sorry about that.