It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm fed up with this.
I'm not going to list everything I've tried. let's just say "everything" that I know of, or can fathom - including brute force clean-ups and reinstallations of both client files, associated registry entries and services and game files - including that !Downloads\Temp file that gets created for this.

Is there something wrong with this game? as my Steam version won't install either.
Does Win10 have a vendetta against it? because, perhaps it can't validate it in its anal-probe database - considering I have the vast majority of Win shyte-pipe intruders disabled, blocked or uninstalled.

ps. It's not my firewall or HIPS either. Or, at least there's no evidence at all that this has been flagged or virtualised - even if, somehow, I wasn't getting informed via the interface.

edit: HAHA! I've just found the ChangeLog notification which states Win10 installation issues have been fixed!!! - uh?... nope, they haven't - whatever they were/are.

It IS Win, isn't it?
It's those two files that others mention: winmm.dll and wsock32.dll
Oddly enough, my Win install has two versions of each; one set in System32 and one set in SysWOW64 and, what's strange is that the only distinctions I can find between the descriptions of each set is that they have slightly different time-stamps and file sizes. It doesn't state that one set are 64 bit wrappers for 32 bit processes or anything else.
I'm guessing that, even if the GOG-supplied C2 was updated with correct versions, Win would still have a hissy fit and block them - on account of them arriving from a different source other than itself, OR, as Win gets updated, a version mismatch would still eventually return a strop-on with an ACCESS DENIED - MS SAYS "NO".

Edit2: Okay, I replaced both files manually using the ones from System32, but had to intercept and prevent GOG from constantly trying to download and install the thing again - which meant I had to, yet again, also manually remove that !Downloads\Temp folder.
I tried running the game from within Galaxy, and from the exe itself, but both throw up a "Couldn't open Key Map file" error before quitting.
Post edited May 29, 2016 by d3v14n7
Don't know the solution, but it look like the access right problem - maybe try to install the game in path like C:\Carma2 ?

About the winmm.dll and wsock32.dll - those are wrappers originally made by Hifi, later releases are modified by GOG.
The same named files in system dir are system files! (do not replace them!).
It work like that - game search for the system files, but first search in it own directory, so found wrappers and use it.
When the files are not present in game dir it search in system and use system files.

When there is no wsock32.dll wrapper (in game dir), game using the default system file which trying to play Audio CD tracks normally from CD, wrapper redirect it to ogg files included with GOG/Steam release.
This wrapper exist in few versions - previous one is included with Steam release, when new one is included in GOG. Older one is XP compatible, when new one is Windows 10 compatible, for other Windows you need to try which one work, if both stuck-crash then you need to remove the wrapper (from game folder).

Same is with wsock32.dll which is IPX/SPX->TCP/IP wrapper which allow to run LAN game. Otherwise LAN game in not possible with modern Windows (for XP you can install IPX/SPX protocol, but the wrapper work perfectly there). So if this file crash you need to remove it (from game folder - for example rename).

BTW: The same wrappers are used in C1 with 95RPP installed (the wsock32.dll is in XP compatible version there).
Have same error, maybe i just refund it.
Nevermind, just download installer.
Post edited June 20, 2016 by KainXVIII