It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I just installed Carmageddon 2 and I have some issues so I can't play :(
1) Random freezes : when I try to go to a menu the game often freeze. (in the start menu or in game)
2) Click doesn't work : after a short random time the click stop working and I can't use it
3) The game freeze each time I try to play so I want to quit it. But when I do alt+tab or I open the task manager I can't interact with it. The only solution I found is to do ctrl+alt+del and to close my session.
4) When I want to change the volume with my functions keys (fn+F11, fn+F12), the car use its horn and I can't stop it.

I tried few compatibility options but nothing change.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Lyz: I just installed Carmageddon 2 and I have some issues so I can't play :(
1) Random freezes : when I try to go to a menu the game often freeze. (in the start menu or in game)
2) Click doesn't work : after a short random time the click stop working and I can't use it
3) The game freeze each time I try to play so I want to quit it. But when I do alt+tab or I open the task manager I can't interact with it. The only solution I found is to do ctrl+alt+del and to close my session.
4) When I want to change the volume with my functions keys (fn+F11, fn+F12), the car use its horn and I can't stop it.

I tried few compatibility options but nothing change.
Best to write to our Support department about technical issues like these. Thanks. :)
Heyyo,

It runs perfectly for me.. are you using the gog version 2.0.0 of this game btw? It uses nGlide 1.0.2 and I've had zero issues with running this game at 1920x1080 and my mouse and keyboard work perfectly.

2) Same goes for my mouse, I've had no issues with it on any menus after playing matches too. What type of mouse are you using? Also, are you using the manufacturer's drivers and software? If yes? Then try uninstalling them.. if not? Try installing them from the latest versions on their website.

3) This game "locks" the keyboard to the game when the application is started. You should be able to quit via alt-f4 as that works for me if you don't wish to back track through the menus. It's the way the game is programmed so not sure if gog can do anything about that behavior.

4) This game did come out before Keyboards had function keys like that so not sure there's anything gog can do about that... hmm, once again, are you using your keyboard manufacturer's drivers? If yes? Then try uninstalling them.. if not? Try installing them from the latest versions on their website.
I received this message from GoG support :
Hello

1) Please make sure that you use "Run as Administrator" to install and to start the game (right click on the shortcut or setup file and select "Run as Administrator").

2) Please add the game to your anti-virus/firewall software's exception/trusted list.

3) Install the June 2010 DirectX runtime package, then use the DirectX web installer.

You can find the ZIP file containing the 2010 package installation files here:
http://www.microsoft.com/en-us/download/details.aspx?id=8109

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

Afterwards, download the latest DirectX web installer and use it as well:
http://www.microsoft.com/en-us/download/details.aspx?id=35

4) Using an unusual DPI setting has been known to cause problems for some games. Please follow these steps to reset it to the default value and let me know if it helped:
I) Right-click an empty section of your desktop and go to “Personalize”,
II) Click “Display” in the bottom-left corner
III) Change your DPI setting to '100% (Default) and confirm by clicking “Apply”.
I did everything it says and I don't have freezes or problems with my mouse anymore so the game is fully playable :)
Now I can do alt+f4 to quit the game if I can't quit properly.

I still have the others problems but I can play with so it's not very important to me.