It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just want to start off by saying I'm not new to PC gaming and I've tweaked countless games before. But this one just refuses to co-operate. Before I even purchase a game, I visit the pcgamingwiki page. It gives me an idea of how much time and effort I will have to spend getting a game to work. According to pcgamingwiki, to remove the stylized black borders, I have to add the lines "DisableScreenBorder()" and/or "RenderViewportProportion(-1, -1)" to the configuration file. I tried putting spaces etc.

It simply does not work. The game also reverts back to 60Hz every time I start it, which is annoying but not game breaking. What is potentially a deal breaker for me other than the border, is the STUTTERING. I think perhaps my CPU has too many cores and the game engine doesn't know how to distribute the workload properly or perhaps it is related to my G-Sync compatible monitor, I don't know for sure, but I intend to mess with CPU affinity settings to find out.

I suppose my question is does anybody know any other fix to remove the black borders or why editing the configuration file in my localappdata (video.scr) isn't working? Any advice is appreciated.

And if you must know, my system far exceeds the system requirements.

Intel Core i5-9600k @3.7GHz with Corsair H55 AIO (userbenchmarks.com gives it a 96%, rank 11 of 1239)
Asus GTX 1660 Super, 6GB GDDR6 (userbenchmarks.com ranks it 43 of 639)
Asus ROG Strix Z390-I (admittedly overpriced motherboard, but still pretty nice)
16GB (2x8GB) DDR4 @3000MHz (basically the cheapest, fastest RAM I could find)
The game is installed to a Samsung 850 EVO 120GB SSD. I also have a Seagate Barracuda 2TB HDD.
My monitor is AOC 27G2 1080p 144Hz IPS using DisplayPort (obviously, can't use G-Sync with HDMI)
My operating system is Windows 10
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well, my reply is probably a bit late for you, what with your post being over a year old now - but I may have some fiddly solutions that could work for you. I was running into all of this stuff and cobbled together various solutions from different forums that worked for me in the process. The issues don't appear to be particular to the GOG version, with the same problems reported on the Steam forums. Anyway ... onto the details.

1. Getting your video.scr configuration file to work.
In my case, the video.scr file worked immediately, with no additional tweaking required. On Windows 10, for me, this file was located in C:\Users\USERNAME\AppData\Local\Techland\COJGunslinger\out\Settings (the AppData folder may be invisible for you, but can be navigated to by either typing in the path in the address bar or by displaying hidden folders in the settings). If you're able to modify settings in this file and see those changes reflected when you start the game, you can skip to point #2 (if that's applicable).

One reason that the file may NOT be working for you is if you are missing a registry entry - or the registry entry differs - specifying where this file (or rather, collection of files and directories) should exist. If you're comfortable using RegEdit, navigate to the folder HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Techland\cojgunslinger - and if the registry folder does not exist, create it. If it's not already there, within the cojgunslinger folder you will need to add a new String, and rename it to 'writedir' (without the apostrophes). Then, edit that string to contain the Value Data 'Techland\CoJGunslinger' (again, without the apostrophes). This is the subdirectory path under C:\Users\USERNAME\AppData\Local, from which the application will look for the various configuration files (so, the complete path eventually being 'C:\Users\USERNAME\AppData\Local\Techland\COJGunslinger' - with further files and subfolders generated within that).

2. Fixing stuttering.
This one was driving me up the wall. The solution that worked for me was relatively easy, though depending on your choice of solution you may or may not need to do this every time you run the game.

This seems to be an issue where the game doesn't understand how to handle too many CPU cores. Option #1, the slightly simpler solution, is to disable access to these additional cores for this specific application once the game is running via Task Manager. Also, be aware that if you want GOG Galaxy to record your gameplay stats and recognise achievements, this is the way you'll probably need to do things. It's also worth doing this at least once, anyway, because this is an excellent way to test and determine which cores need to be disabled in order to get things working correctly - this is information you will need even if you are going with option #2, further below.

To do this, open the game (to the menu), and make sure that the game is running in Windowed Mode. Windowed mode will allow you to Alt-Tab out of the application but allow you to get back in again afterwards (in fullscreen mode, I was able to Alt-Tab out, but couldn't reliably get back to the game - your experience may differ).

When back at your desktop, open Task Manager: Win+R (opens the Run box) > type TaskMgr (press enter). On Windows 10, switch to the 'Details' tab. You should now see a list of executables, by their actual filename (closer to what you would have seen in the first place under Windows 7, if I remember correctly). Locate CoJGunslinger.exe, right-click on it and choose 'Set Affinity'.

The 'Processor affinity' window will now appear, asking "which processors are allowed to run CoJGunslinger.exe?".

In my case, with an i7 4770k, I left threads/CPUs #0-3 enabled (the first four) and DISABLED threads #4-7 (the last four). On the i7 4770k, I know that there are 4 true cores, with 8 threads - but whether CoJG freaks out with too many cores or freaks out when running on virtual threads I don't know ... but this is what worked for me.

Click okay and return to the game. The stuttering will hopefully be entirely or almost entirely gone.

Setting Processor affinity in this way will require you to set it every time you run the game. It's fairly quick to do once you're comfortable with the process.

If you don't mind putting in a little more effort, you have option #2 available to you - it's a bit fiddly, but only has to be done once. Essentially, what we're doing here is setting the Processor affinity by way of some extra parameters in a shortcut to the game's executable.

So, the steps are as follows:

* Locate the folder in which you've installed Call of Juarez Gunslinger (something like 'C:\Games\GOG Galaxy\Games\Call of Juarez Gunslinger', or whatever location you use to install games).
* By default, there is already a shortcut in this folder to the 'CoJGunslinger.exe' file, but you can copy the pre-existing shortcut or create another from scratch if you want to have the shortcut stored in a different location such as your desktop or wish to keep the original one intact.
* Right-click on your (possibly new) shortcut and choose 'Properties'.
* On the 'Shortcut' tab, adjust the 'Target' field to something like the following:

"X:\path_to_game\CoJGunslinger.exe" /c start "Call of Juarez Gunslinger" /affinity F

Explanation:

* Replace 'X:\path_to_game' with the correct path as it applies to your computer.
* The latter parameter, '/affinity F' will likely be different for you, depending on your processor. In order to determine the correct value (for me, with my processor, it was 'F'), we need to know which cores you want to have enabled or disabled - which you will have hopefully determined by following the steps described earlier. There's an excellent explanation of the whole process here, but in case the page is no longer available or if you want to cut to the chase, here's how it works ...

** You need to take note of a binary string representing how many threads your processor has (this will be the same number as the number of 'processors' you can enable/disable using the Processor affinity option for each executable in Task Manager). For now, just take note of this number - we're not using it anywhere yet.

An 8 thread processor (such as the i7 4770K) will have a default value of 11111111 - that's eight 1's - with each digit representing one thread. If you have a 12 thread processor, this would be 111111111111, or a 4 thread processor would be 1111, etc. Now, for every thread you wish to disable, change a digit to 0 - with your first-to-last thread represented from right-to-left. So, to disable your LAST core only (on 8 thread processor), this binary value would be 01111111. Or to disable the 2nd and 3rd threads only, the number would be 11111001. In my case, I wanted to disable the last four threads, so the binary value that was correct for me was 00001111.

Now, you need to convert this binary number to a hexadecimal value. Assuming you don't know how to do this, just search for 'Binary to Hex converter' in your search engine of choice (or you can use the one here). 00001111 converts to a hex value of 'F', so this was the correct value for me - and this is what we're using in our shortcut, hence:

"X:\path_to_game\CoJGunslinger.exe" /c start "Call of Juarez Gunslinger" /affinity F

If your hex value is more than one digit that should be fine, too. For example, 000000111111 has a hex value of 3F.

So, once you've updated your shortcut and saved the changes, you should now be able to start the game via that and not need to mess with it again. However, using this custom shortcut will bypass GOG Galaxy, so any achievements or gameplay stats will not be recorded by Galaxy. If this doesn't bother you, then you're good to go. If it does bother you, you'll need to set the Processor affinity manually every time you run the game - as described first.

These are the only solutions that have worked for me regarding the stuttering. If you've searched for other solutions you may have seen various things that refer to keyboard and mouse settings - to my knowledge that was a separate stuttering issue that was resolved in an official patch, which is presumably why solutions to that issue made no difference for me.
Post edited September 20, 2021 by RedRabbitRun
3. Enabling anti-aliasing.
Okay, this isn't something that was mentioned or asked about in the original post - but is is the remaining issue that bothered me when playing the game. You might have noticed that anti-aliasing either doesn't work (whether using the custom config file or not), or simply doesn't affect foliage/grass - of which there is a lot. The lack of anti-aliasing I found to be quite uncomfortable when playing the game on my 1080p monitor.

There is a solution, for most NVIDIA GPU users, particularly if your computer's specs are comfortably above what is required for this game (which will probably be most of you, given that it's a number of years old).

Open the NVIDIA Control Panel. Go to 3D Settings > Manage 3D Settings > Global Settings (tab). You should see a setting named DSR - Factors. Enable as many increased native resolutions as you like - I ticked everything 2.00x and above (2.00x, 2.25x, 3.00x and 3.00x). Click 'Okay' and 'Apply' the changes.

What's happening here is that DSR (Dynamic Super Resolution) allows you to choose resolutions that are above what you might typically use on your computer/GPU. These resolutions can be beyond the capabilities of your monitor. Then, within a game or application, when you choose these increased resolutions, your GPU will render the high-res frames but shrink them down to display at your monitor's native resolution. However, because the frames were originally rendered at a much higher resolution, they retain all the smoothness that you would have had with really nice anti-aliasing. Jaggies should be GONE.

So, with that done, run the game and within the game's display settings first make sure that you are running the game in full screen mode. NOT in windowed mode.

Now, check to see that you have access to increased resolutions. If, for example, your highest resolution was previously 1920x1080, you should now be able to select 3840x2160. Do so, and you should find that the game still displays quite happily on a 1080p monitor - but with much smoother visuals where previously-jagged edges are concerned, even without any anti-aliasing. Be aware that the game IS running at the higher resolution under the hood - so having a GPU that's comfortable with the extra demand will ensure that you enjoy a decent framerate.

One further point to be aware of ... if you are using the Processor affinity fix for stuttering mentioned above as well as NVIDIA DSR as a substitute for anti-aliasing, you will need to FIRST switch to your native resolution and windowed mode in the game menu before you Alt-Tab out to set your Processor affinity. You can then re-set your increased resolution and fullscreen display settings once the Processor affinity stuff is dealt with. Because, again, in my experience Alt-Tabbing out of the game/application in fullscreen mode (especially at a higher resolution than my actual monitor supported) made it impossible to get back to the game from the desktop.

So, yeah. It's all a bit of a pain, but it can be done and it's easy to remember how once you've done it once. The NVIDIA DSR thing is a nice option to have in your pocket for any game that doesn't support or fully support anti-aliasing, too (and you don't need to have GeForce Experience installed either, FYI).

Hope that helps someone.
Post edited September 20, 2021 by RedRabbitRun