It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

While the game does recognizes my generic USB Gamepad as an XBOX controller without much issue, the upper buttons (RT, RB, LT, LB) are inverted, with RT being detected as RB and the same for the left side. I have no problems "remapping" the controls on the option, but the game still registers the controller in an inverted way, so whenever I am prompted to press RT, it signals me to press RB (and viceversa).

I tried using "x360ce" for 32-bit, and while the program beeps upon executing the game, is like it made no change at all. I have also tried using "xbox360cemu 3.0" (which solved my problem when I had a similar issue with Darksiders), but when I put it in the directory, there is absolute no response from the part of the controller, like it was not even plugged and I am forced to use the keyboard to exit the game. I'm running the game on Window 7 Ultimate 64-bit with no issue at all, except the controller recognition. Any help would be much appreciated. In advance, thanks.

Also, I don't know if this is an issue of just part of how the game works but I have noticed that, while I can rotate the camera with the Right Analog Stick, I can't move it up or down, only left or right. The Left Analog Stick works without issues.
Post edited March 28, 2017 by SeemosYantra
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hey, after googling enough, I managed to brew a solution of my own. I'll post it here in case anybody is having the same issue:

For some reason, it seems the file that contains the default button mapping detects both the afore mentioned buttons wrong, including the Right Analog Stick. What I did was change the mapping manually by editing the configuration file and it worked like a charm. You can find the configuration find as "C:/GOG Games/Brutal Legend/Data/Config/SDLGamepad.config" (of course, I have my GOG games installed on drive C, so if you have them installed in any other drive, the letter may vary). You can open SDLGamepad.config with Notepad. Since I am using a Generic USB Gamepad to play, I had to modify the button values for the both the Right & Left Triggers and Right & Left Shoulders, as well as the X and Y Axis of the Right Analog Stick. As such, my configuration looks like this:

# Generic controller with rumble

Note: you will also see configurations for other controllers listed on the file, but you need not touch that, of course. Naturally, once you are done with the change, save the file and try running the game to see if your problem is fixed. I hope this help any folks out there having issues with Gamepad controllers like I was having.
GOOD topic. Finally got mine to work properly (controls were inverted, x360ce didn't work, right stick didn't work).

Here's my DualShock 2 configuration:

bd1202e0000000000000504944564944,Dual USB Vibration Joystick,a:b2,b:b1,x:b3,y:b0,back:b8,start:b11,leftstick:b9,rightstick:b10,leftshoulder:b6,rightshoulder:b7,dp up:h0.1,dpdown:h0.4,dpleft:h0.8,dpright:h0.2,leftx:a0,lefty:a1,rightx:a3,righty:a2,lefttrigger:b4,righttrigger :b5,

(no code function, so delete spaces before "USB" and "Vibration")

I'm using a generic USB adapter with it (the Chinese blue one).

If your controller doesn't work, use this tool -

Map the controls and then copy and paste (without quotes ["] or apostrophes [']).
Post edited April 28, 2017 by FraX
Oh, you can also add PlayStation icons. Add this line

sDefaultControllerIcons = "PS3"

to "Buddha.cfg" in Data/Config/
So I'm also having some very frustrating difficulties here.

For some reason, the game detects my PS4 controller (just plugged in via USB) but it's completely ignoring whatever I set in the SDLGamepad.config file.

I've tried editing the file in \Brutal Legend\Data\Config\ and also the one in C:\Users\username\AppData\Roaming\Doublefine\ but whatever I do, it's just ignoring it. So the game thinks my X button is actually the cancel button and the square button is the accept button, amongst other things, including thinking R2 is the start button. What I do it's just ignoring what I tell it and it's setting it to whatever it wants. I don't know where it's getting the button mappings from but it's not using the ones I'm telling it to use.

I've tried using the SDL gamepad tool to generate the mapping, and copying that into the files, but it just doesn't actually care. In fact, as an experiment, I tried deleting the SDLGamepad file out of \Brutal Legend\Data\Config\ completely and the game still happily started fine without it even there, so I'm convinced it never ever actually looks at that file, so editing it makes zero difference. Deleting it from AppData\Roaming\Doublefine\ caused it to regenerate on game startup, but it still ignores any controller mapping you put in there. I tried just putting gibberish in the file and the game never complained, so even though it generated the file I'm not convinced it ever looks in there either.

I want to make it clear, I tried the above suggestions and they DON'T WORK. Oddly, I could change the button icons easily enough, but the actual button mappings can't be changed. Since the game seems to be ignoring what's set in that SDLGamepad file, I can only assume there's yet another file somewhere it's reading those settings from, or it's hard coded into the game and can't be adjusted.

And no, I don't have an SDL environment variable set.

I'm beyond frustrated at this point. WHY is the game totally ignoring the settings in this file?!?!?!?!
Post edited October 03, 2018 by wh1tepointer
Yep, after wrestling with this some more I'm convinced this game's controller support is just broken. It's not even working correctly when I use DS4Windows to fool it into thinking it's an Xbox controller, something that shouldn't ever happen. It's just completely broken. Whatever I do, it's using some kind of predetermined controller mapping that is ignoring everything I try to do to remap it.

I'm running on Windows 10.

How do I ping GOG staff to bring this to their attention? Controller support in this game is broken. @GOG-Team ?