It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm using a Lenovo Legion Y720 with in integrated Intel chipset and an Nvidia GTX 1060. I can launch the game without any issues using the Intel chipset but it keeps crashing on start-up when I'm trying to get it to open using the Nvidia chipset - so it's working, kinda, but as you can imagine, that Intel chipset isn't the strongest horse in the stable.

It appears to be a PhysX-related issue, and I already tried various older PhysX versions. All I'm getting is a longer or shorter list of general protection faults depending on the version. Unfortunately, it still won't start with the 1060. Any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Not entirely sure why but it's working now. Uninstalled the PhysX Legacy driver that came with the installation, installed PhysX 8.04.09, rebooted several times - now it's working!
i,m havibg the same problem. tried verifiying first time and it worked, played for hours, then today (next day) got same General protection message before it starts, tried verify/repiar and still get same message WTF GOG please advise. 22/01/19
Yeah, verifying didn't help in my case either.

Here's what I did, thanks to something I saw on a reddit thread:
- install the game
- reboot
- uninstall "PhysX Driver (Legacy")
- reboot
- download PhysX 8.09.04 and install (yes, that means you'll have two PhysX releases running in parallel - this old one and the current one that came with your Geforce drivers)
- reboot
- make sure your Geforce drivers are up to date, maybe reinstall them (who knows - you're already rebooting and reinstalling so many things anyway, it's not like this makes it any worse...)
- reboot!
- maybe, just maybe, play the game. Until the next driver update, I guess.