It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I've tried every suggesting involving compatibility mode, editing the compat.ini (m_bDSoundLocForceSoftwareOn) and nothing is fixing the Voices being cut off. It happened in BS1-3 but not to this extent. It's unplayable without subtitles and annoying with them on.

There has to be a way to fix this. Anyone? Windows 10 if it matters.
No posts in this topic were marked as the solution yet. If you can help, add your reply
The solution involving the compat.ini file requires the change of both these values:

[EmAudioManager]
m_bDSoundLocDeferOn = 0
m_bDSoundLocForceSoftwareOn = 1
Anyway, another solution could be to add the "-compat-on" parameter to the game's executable.
Right click on the game's shortcut, click on Properties and select the Shortcut tab. Add "-compat-on" (without quotes) at the end of the Target box, after the last quotation mark. Apply then run the game.
avatar
dr.schliemann: The solution involving the compat.ini file requires the change of both these values:

[EmAudioManager]
m_bDSoundLocDeferOn = 0
m_bDSoundLocForceSoftwareOn = 1
avatar
dr.schliemann: Anyway, another solution could be to add the "-compat-on" parameter to the game's executable.
Right click on the game's shortcut, click on Properties and select the Shortcut tab. Add "-compat-on" (without quotes) at the end of the Target box, after the last quotation mark. Apply then run the game.
Doesn't help. The speech continues to be cut off. Honestly I was tired of tearing my hair out so I'm living with it. Very badly designed game in terms of the technical side. Seems theres a visible 'skip' when the audio issue occurs. I can always predict when it happens, so I read ahead.

Then we have the 3D memory leak. If you stay in large areas too long the game slows to a massive crawl. Exiting and restarting the game fixes it.
avatar
dr.schliemann: The solution involving the compat.ini file requires the change of both these values:

Anyway, another solution could be to add the "-compat-on" parameter to the game's executable.
avatar
avatar_58: Doesn't help.
Have you tried editing the ini file and adding the parameter together? Maybe using a compatibility mode too?
avatar
avatar_58: Then we have the 3D memory leak. If you stay in large areas too long the game slows to a massive crawl. Exiting and restarting the game fixes it.
I am not sure, but performance issue could be related to multicore CPU too.
Try editing the file custom.ini. Locate these lines:

[EmThreadManager]
m_uiUseExtraProcessors = 0
Change 0 to 1 and save the file, then run the game.