It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone,
I've been trying to play Brigador with my 360 gamepad but found the controls extremely twitchy. That problem applies in the menus as well. I believe this is because there is no deadzone for the analog sticks defined. So every little inconsistency from the sticks is directly translated into movement.

Does anyone know of a way to change the deadzone for the controller? Any help would be greatly appreciated.

##### NEVERMIND #####
After restarting my computer the problem was gone. It seems to have been a bug in the 360 driver software or something.
Post edited June 03, 2017 by Beaumont81
If anyone else has similar issues, here is a guide for customizing the deadzone via config files:

Well, apparently I can't post links. It's "Having Controller Deadzone Issues?" under the Technical Issues forum on Steam.
Just an FYI, Microsoft's Xbox 360 controller driver does not have a dead zone option. Not sure why as all joysticks seem to develop problems as they age. Oh well.

A good alternative is third party software like Xpadder (which I use), JoyToKey, or Pinnacle Game Profiler. Google them for more info.

Or just modify the INI files like the Dev suggested ;^)

From Steam forums:

Having Controller Deadzone Issues?
Some people have issues with controllers behaving as if there is no deadzone. There is supposed to be one. I have never been able to reproduce the issue on the controllers I had access to: wired xbox 360 controller, dualshock4, xb1, steam controller.

It seems like most people with the issue had 360 controllers. My guess is that some 360 controllers have deadzones that are even larger (perhaps through wear and tear).

Useful infomation here would be what controller you are using.

From a previous thread:

There is a hidden way to adjust the deadzones. If you browse the game directory on Windows and Linux there should be a profile.json that gets generated once you start playing. You can add "leftStickDeadzone", "rightStickDeadzone", and "triggerActivation" with values from 0.0 to 1.0. Follow the format of the file and watch out for the commas. So you may end up with something like:

"sensitivityNear": 0.100000,
"sensitivityFar": 0.250000,
"sensitivityCoarse": 0.600000,
"leftStickDeadzone" : 0.24,
"rightStickDeadzone" : 0.27,
"unlocks": ...

Those numbers should be what XInput recommends for the 360 controller (by default we used 0.25 for both). My experience with the 360 controller is that the deadzones are massive (over double that for PS4/XB1 controllers) and it doesn't like to recenter properly (and the dpad is a crime against nature). In Windows itself, there is a menu for Game Controller settings which visualizes the controller input as well as a calibratation tool that I've never used.

The profile.json file is cloud saved, so you may gets prompts about syncing it if you edit it while the game is not running. These setting are applied to any controller used.

On Mac, the file should be the Application Support instead of the install directory unless the app is sandbox (only the Apple App Store version should be sandboxed), in which case it will probably be somewhere in ~/Library/Containers/ (exactly where depends on who signed it and with what settings).


If this helps, let us know what values you are using so we can change the default values.
Last edited by hexateron; Jun 3 @ 8:08am

I added

"leftStickDeadzone" : 0.25,
"rightStickDeadzone" : 0.25,

right above "controlSchemeTank": 2, and it worked perfectly. Remeber to back up your original profile.json just in case.
Post edited June 09, 2017 by StudiosWest
I have already seen this problem on different games: Mars: War Logs / Bound by Flame / The Saboteur ...

So, I tested the game with several controllers.

Result :
X-input controller = Sticks dead zone problem.
D-input controller = No dead zone problem.
Post edited March 29, 2022 by FlaW313