It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Alright Blood fans this is how to run Blood 2 with no problems at all on xp or other windows
Go into the your Blood 2 folder and click on the file called autoexec.cfg it will be a notepad file go into it and type anywhere on the left handside "MaxFps" "30"
Now if you don't wana type it in everytime you play blood 2 also do the same to the defaults file in the folder
now click on blood 2 and you know that box comes up with different options click on Advanced and tick these options
Disable directX 6 commands
Enable optimized Surfaces
Enable poly gap fixing (slower)
Enable triple buffering
and tick Always specify these command-line parameters just to be on the safe side but don't type anything in the command-Line box
Now turn on blood 2 and bring up the console by pressing ' after about a maximum of 5 seconds or more the screen should flash turn the console off and the menu doesn't flicker and blood 2 will be absoutely fine you have to do this everytime when you launch blood 2 you don't have to do it when you go on the next level i mean turning on the console but it's only for 2 seconds

What you read was the default how to get it working. With Windows 7 this holds true to a point.
The EXE files need to be administrator, myself I also took total control under my username as well. As for crashing you need to start the game on default resolution and bump up from there inside the game not in the launcher. The main crash areas are at level transisitons. personally i cannot go above 1440x900 or i crash. On my Laptop with a Nvidia card i cannot use any widescreen resolutions at all without crashing on level transition.
So to recap the major points, in the launcher tick:
Disable Direct X 6 commands
Enable optimized Surfaces
Enable poly gap fixing (slower)
Enable triple buffering
Always specify commands line parameters
Edit the autoexec and default file inside the blood 2 install folder and add
"MaxFps" "30"
as for screen flicker and edge the Console trick does work about 50% of the time.
if you want to bypass launcher once settings are good and have no need for it, launch the game from Blood2.exe and add the command line "-gogame" and that should remove the launcher.
once you find a suitable resolution that wont crash you edit the autoexec and default files in the install folder and use the command line shortcut.
if all else fails go into DXDIAG through the control panel and drop your hardware acceleration down a notch at a time and see if it'll work.
lastly there is always software mode, which is kinda fun in an odd way!
Post edited May 12, 2010 by Starkrun
If you thought the last guy's advice was good, use my recommended settings for quake3!
First you create an autoexec.cfg in your baseq3 folder.
add the below:
set cg_simpleitems "1" // turns items into sprites
set cg_gibs "0" // No gibs.
set com_blood "0" //no blood.
set cg_marks "0" //No marks on the wall.
set r_lodbias "2" // makes the geometry look terrible.
set cg_drawgun "1" //draws gun, off or on doesn't matter. lod already makes it look bad.
set cg_shadows "0" //no shadows.
set cg_forceModel "visor" //see only one model
set cg_railTrailTime "0" //can't see railgun
set com_maxfps "33" //artificially limit your framerate.
set cg_drawfps "1" //see how slow you made the game run.
set cl_run "0" //move slow
set r_dynamiclight "0" // No lighting effects!
set r_fastsky "1" //doesn't show the sky.
set r_vertexlight "1" //disables all shading.
set r_picmip "5" //blurry textures
set r_roundImagesDown "1" //more blurry textures
set r_detailtextures "0" //less detail.
set r_texturemode "gl_nearest_mipmap_nearest" //horrible texture filtering
set r_texturebits "8" //texture depth
set r_colorbits "16" //bit depth
set r_mode "0" //320x200
set s_loadas8bit "1" //crappy sound.
set s_khz "11" //even worse sound.
set s_doppler "0" //less sound effects
set s_ambient "0" //no ambient sounds
bind d "+moveleft"
bind a "+moveright"
bind w "+back"
bind s "+forward"
bind SPACE "+movedown" //lolol
I take no responsibility if you totally screw up your games by following any of the above advice.
Everyone should use common sense in configuring their games, and if disabling dx6 and limiting your framerate sound like good ideas, then by all means do so.
Just don't ask other people to do it too.
FYI, screen flicker is caused by the 3d desktop in vista and w7.
Using compatibility options like "disable visual themes", is the proper way of handling the situation.
Post edited June 09, 2010 by Entropy