It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Here's how I got Blood 2 working fine again on Win 10 - no framedrops or crashes.

I got this info from (cough, spit) Steam, so credit to M!ki who wrote the original guide.

First, click the links to download the following:

1. Blood 2 Res Patch

2. dgVoodoo2

3. Blood 2 Widescreen Patch

Extract the files, then follow these instructions:

1. Go to your Blood 2 installation folder; for me, it's GoG Games/Blood 2.

2. Overwrite "client.exe" with the new one from the Res Patch.

3. Create a new folder called "Custom" in your Blood 2 game folder.

4. Move "WidescreenPatch.REZ" and "WidescreenPatchNm.REZ" files into the Custom folder that you have just created.

5. Move "dgVoodooSetup.exe" file into your Blood 2 game folder, open the MS folder, then move D3DImm.dll and DDraw.dll files there as well.

6. Open "dgVoodooSetup.exe" and configure settings as you prefer - I recommend switching off the Watermark under the DirectX tab, as well as confguring your resolution.

7. Run Blood 2 and go to the "Advanced" tab in the game launcher.

8. Change the settings so they match this image.

9. Go to the "Customize" tab in the game launcher and move the "WidescreenPatch.REZ" file to the right side, then check the "Always load these rez files" box below.

NOTE: If you want to play the Nightmare Levels expansion, you'll need to replace the above step with the "WidescreenPatchNm.REZ" file.

10. Play the game!

Hopefully this will work like a charm for you as it did me.
Post edited October 15, 2015 by madhair60
Thank you, thank you , thank you !
Little update.
As of now (2020-11-05) dgVoodo was updated to version 2.71.3 and can be downloaded from http : // dege.freeweb.hu/dgVoodoo2/dgVoodoo2_71_3.zip and the file is not longer called `dgVoodooSetup.exe` but `dgVoodooCpl.exe`
Thanks for your help but unfortunately I have a problem.

I'm also running Windows 10 in 64 bits and when I launch the game seems to go full screen for 1 second, but it gets stuck with a stupid black screen (see below) in the upper left corner, and of course I just hear the sound of the game during the intro but I don't get any pictures.

I followed your tutorial to the letter, what's going on ? help.

Bug:
https://mega.nz/file/IJdw0BQC#843PAFzdvloDJ5MymqrNbehFlw8nE02rKWT-syHrRUA

I specify that in the tab "Display" by default my Rtx card was selected but even changing for Wrapper dgVoodoo, I still have this damn bug. x(

Display:
https://mega.nz/file/JJUkCRTY#8rWcbkYf368NI6ABX_UuIDO83RETiSCaa78Tku_JQ3E

Edit:
Resolved: "Make sure Disable Fullscreen Optimizations is still checked as it is a client.exe replacement".
Post edited January 06, 2021 by thedkm
avatar
thedkm: Edit:
Resolved: "Make sure Disable Fullscreen Optimizations is still checked as it is a client.exe replacement".
Just want to say thanks. I was having the exact same issue and this fixed it.
Now i know, why this shit were bein taken off from GOG, but I want to play it. so tell me. Why the fuck, I cannot start a purchased game. Is it the same issue with Cyberpunk? I am waiting for an anwser.
I ran into the same issues, and after fiddling around I am now back where I started with instant crash on start.
avatar
thedkm: Edit:
Resolved: "Make sure Disable Fullscreen Optimizations is still checked as it is a client.exe replacement".
I looked around and I do not see this option anywhere. Can you provide some detail on where this can be located? Thanks in advance

---Bah, found it. Windows Properties. Working now. Thanks!!!
Post edited August 05, 2021 by djkurzman