It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

disgraciau: This happened me too with the retail version in my modern laptop. The only fix i found for this, are these two:

*Open a game that consume CPU resources (Crysis, Minecraft, etc.). The point is make the CPU work a bit hard. Then, minimize the game, open Blade, and play it. If you see that the speed is correct, minimize the game, and close the "CPU-eater game" that you have opened before.

*Download "Swords & More" mod. It's a mod that have lots of features, including an "speed adjuster". With this you'll be able to correct the roadrunner speed of the game with a couple of hotkeys. The problem of this mod is that it's "cheater", and makes the game easy unless you de-activate some options of this mod. Also, Mod Manager is required for make this working.

I would like to beg to GoG (without thanking them before the release of this masterpiece), that try to make a fix from the "Swords & More" mod that allows you modify the in-game speed for the people that we have this problem.

That's all. Thank you.

P.S: Sorry for my bad English.
Not trying to brag TOO much but our version has that problem fixed :D
disgraciau: Tried one more time, it keeps running fast as roadrunner to me. I need to have a game opened to make it working at normal speed.

I don't understand it, really, and even less when this issue is fixed.

Maybe something related with laptops or something? I don't know.
I am sorry to hear you're having problems with our version of the game. Please write to our Support department and make sure to send in your DxDiag info along with the mail. Thanks :D.