It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Most problems with this game can be solved by selecting rOpenGL as the renderer/rasterizer, it is a mod made by the original devs of the game to solve graphical issues which have arisen with newer graphicsdrivers.
Post edited March 13, 2013 by Strijkbout
I also encounter that "speedy bug". Restarting the game, as supposed by Darucas, solves that issue for me. Sometimes, but seldom, I have to restart the game two times. Very odd behaviour, indeed. Not game breaking but a bit annoying...
I ran into the same problem, and here is what worked for me: I installed the cpukiller as mentioned by YaTEdiGo above and started it at 30 percent, started the game and it runs smooth. Unfortunately the game started stuttering after a while. So i pressed the windows key to go back to the desktop (with the game still running), stopped the cpukiller and returned into the game. Suprisingly the game did continue running smooth without stuttering :)
Post edited June 07, 2013 by AquilaRapax
Same issue for me. I've contacted the support team and now I'm waiting for an answer. I'll recap my situation just to see if it may be helpful to someone.

I have a Win 7 32 bit OS installed on a laptop (Acer Aspire 9410z). My VGA is an Intel 945, 2GB System RAM.

I tried to start it in D3d mode, several resolutions, obtaining unnavigable menus and fast as light gameplay.
Tried to switch to openGL obtaining navigable menus, but having anyway a too fast gameplay (some times it slowered down but probably because I could activate more effects slowing down my bad laptop).
In the end I tried to start it in 3dfx mode (should be available because of the support to nGlide) but it didn't start at all.

I really would like to play it normally and in 3dfx if possible. Any Solution?
@Alexkenaviga, did you try the cpukiller solution, that i proposed? Install cpukiller and start it. Set the percentage to a value that fits (for me it was around 30%). Then start the game and choose "start a new game" (i have to do this every time i want to load a game either). In the character selection screen the game should run normally or a little slow (maybe stuttering) - that is because of the cpu-killer. So press the Windows key, to come back to the desktop and stop cpu killer - i guess the game calculates some speed-factor, so you must not close it. When you go back into the game, it should run in normal speed. Probably you have to figure out the right percentage value for cpukiller, but for me it works. BTW i run the game in rOpenGL.
Post edited June 11, 2013 by AquilaRapax
When using the rOpenGL renderer you can solve this problem by forcing vsync and tripple buffering with your graphic card drivers. I don't know about AMD/ATi or Intel cards, but with NVIDIA you can do it from the NVIDIA control panel. This panel also allows to add some other fancy settings such as anti-aliasing to make the game look even better.

On the other hand, when using the rOpenGL render you can just adjust the lightning parameters to get rid of the default washed out look. You can do it from the settings option of the game launcher, under the 'color' label. I've found 'gamma=0, brightness=4, contrast=2' to be quite pleasant to me.

Btw, GOG version doesn't include neither the latest patches nor the latest OpenGL renderer (at least they are not in the Spanish Language pack), it would be great having those included. As times goes, is becoming harder to find them in internet and they solve quite a few issues.
I have the same issue, and would love it if GOG would be able to find a real fix. Other fixes don't really seem to work: CPU killers make the sound choppy, and cranking up the graphics settings just makes the framerates inconsistent - depending on where you look, the framerate varies wildly, so you slow down while looking at fire, and speed up looking elsewhere.

For what it's worth, I'm using an ATI card in a Lenovo T60 laptop. Forcing Vsync (ATI's "Wait for vertical refresh: On") doesn't help, and I've tried many of the different video drivers. rOpenGL does seem to produce the nicest rendering, and once and only once it ran the game at the appropriate speed, though I have serious problems with vertical flickering when using that driver.

This game is pretty unplayable in its current state for me (and obviously for a number of other people.) It would be nice to hear something more from the GoG staff than just, "We've fixed this, don't worry" considering it is still clearly a problem for many users.

That said, this is the first GoG I've had any trouble with, so that's a pretty good record!
I'm also having this issue which renders the game unplayable. Oh well, at least it didn't cost me much.
The problem is in multicore processor. Just try to run the game with "start /affinity 1" parameter. For example: "D:\Games\Blade of Darkness\Bin\Blade.exe" start /affinity 1

This helped me and now i can enjoy the game without any problems.