It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I know it was just released today so it may need some bugs worked out, but I cant get it to Launch at all. I downloaded it & installed it just fine but it Crashes every time I try to Load it, I cant even get to a screen to change the Settings. I did take a look at the install folder to see if it had a Txt File with Settings to try & run it Windowed the first time or something but I did not see anything like that. I also Tried using my Radeon Control Panel to Adjust the Game Settings with the Video Card itself, like turning Antialiasing On/Off or V Sync ect. To no avail.

System Specs
OS: Windows 7 64 Bit
CPU: i7 4790
RAM: 16Gb DDR3 1600
Video Graphics Card: RX 580 8Gb
Storage (where Game is installed) 1Tb SSD SATA

All the Updates have been installed & I have the latest Driver. I will try to install this tomorrow on another PC or 2 just to see if I have the same issue. I will chck back tomorrow. Here is the Crash info,

Problem signature:
Problem Event Name: APPCRASH
Application Name: Blackwind.exe
Application Version: 2019.4.31.23231
Application Timestamp: 6152dcdb
Fault Module Name: UnityPlayer.dll
Fault Module Version: 2019.4.31.23231
Fault Module Timestamp: 6152dd01
Exception Code: c0000005
Exception Offset: 00a07fcd
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

EDIT: So I think I know what the issue is. This Game most likely needs the infamous Evil Update for Windows 7 KB2670838, which crashes most Direct X 10 Applications. On Windows 10 this isn't an issue but I still use 7 as my daily driver for many reasons. I hope they Patch this out so you don't need that stupid Update. Turok has the exact same issue from what I can tell
Post edited January 23, 2022 by dhgodzilla1
No posts in this topic were marked as the solution yet. If you can help, add your reply