It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

There is no exit from the troop purchasing screen. The arrow back is a dead link. Kind of makes the game rather impossible to play once you finish the Initiation (tutorial)!

Oh, OK, it seems I tried to leave without an army and the game would not let me. OK, makes sense.
I do hope they can get the Introduction working.
Post edited July 10, 2016 by Adwoa
That's weird, I've never encountered such thing (and I've played both in polish version and english from GOG). Have you tried to re-download installer and install it once more?

I'm aware that BMC is EXTREMELY bugged, but this thing should work always. Have you tried to use "r" button? (it should be only used to go out from the castle, but I don't know, maybe it will work in your case - in my case it doesn't, but I can use "return" arrow without any issues).
Post edited July 10, 2016 by Knuckles_the_Echidna