It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

To disable DLC delete the corresponding folder in the following directory:

..\GOG Games\BioShock Infinite\DLC
You do not have to delete the folder actually. You can just rename it or move it elsewhere in case you want to play the DLCs later. This way you do not have to download and reinstall the whole game once again.