It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

On Windows 10, Bioshock 2 crashes on startup for me. A white frame pops up as if the game will launch, then immediately it closes. If I force DX9 mode it will stay open but the game will not run.

The save game fix won't work since I am yet to even get to the game's menu screen. Still, I deleted the folder just in case and nothing. I also tried different compatibility modes, no compatibility modes whatsoever, uninstalling and reinstalling, verifying the game integrity, using the BioShock Tweaker, all to no avail. The weird thing is that the first time I launched the game it worked fine. I never made it past the menu, didn't touch any settings and didn't save the game in any way shape or form. But closing it after that, it simply refused to run again.

Any help would be appreciated.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I confirm! Identical problem. A week ago, everything worked. I think this is due to recent Windows updates.
I found out experimentally that the problem arose due to the automatically updated NVIDIA 432.00 driver. Rollback to the older 430.64 or the last 441.66 fixes the problem.