It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I am fed up, none of Remastered or normal version does launch.

I have
* Windows 7 Home SP 1 (as in the game spec)
*.NET Framework 4.7
* Redist MSVC: all in x86 and 64 bit Versions.
- 2005
- 2008
- 2010
- 2012
- 2013
- 2017

I have already installed (even before for all the other games which work - Stellaris & others were picky too):
- DirectX 11
- Platform update Windows 7

Does anyone got an idea or even real knowledge of what the hell to try?[url=][/url]
Have you tried uninstalling update KB2670838
(uninstalls Internet Explorer)
Post edited April 01, 2019 by andytheGamer
Thank you for the hint but - yes, I just did and restarted, nothing changed, still just a crash without a word.
I would guess that it rather needs something that is not there or accessing a dll that is not right.

Actually for everyone who wonders: The KB2670838 update is the "Platform Update" - which should be besically required to run the game...

EDIT: Solved the issue - turns out that the reason were DLLs of Microsoft. They are contained in the update KB2999226. Praise to Bill there.... Other software knew of the issue and brought their own so the game tried to take those but they were an older version causing the error. Why the new game tried to take toe ones from the other software's path I do not know. I deinstalled the other software and copied the libraries directly to the executable and it worked.
Post edited December 09, 2020 by Sierra