It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
squid830: Just to ensure I haven't gone totally mad, are you @thebream also using Windows 7 like @kaileeena, or are you on WinXP?

Thanks for detailed reply. I contacted GOG support and they are awesome I have to say. Here is the reply for any is interested in removing the alt-tab disable:

Please go to the game's directory (default: C:\GOG Games\Beyond Good and Evil), Open the Notepad and enter:
sdbinst -u gog_beyond_good_and_evil.sdb

Save the file as remove.bat in the game's folder, right-click on it and select to "Run as administrator".
avatar
kaileeena:
Of course! It was so simple!

JK :)

Wouldn't have figured that out. Didn't even know about the existence of sdbinst. Guess you learn something new every day. Looks like this was part of Windows since 2008, but must have gotten more use with the release of Vista/Windows 7.

I guess there are more differences between the XP and Windows installations than I thought...
avatar
thebream: Reinstalled the game. Tried this. Still not working. Also, the disablealttab field wasn't there and I had to create one.
avatar
squid830: Just to ensure I haven't gone totally mad, are you @thebream also using Windows 7 like @kaileeena, or are you on WinXP?
Sorry I havent been active enough to reply earlier. Things have been a bit hectic for me in the past few weeks. I'm using Windows 7 64 bit.


In regards to the registry folders, I have

HKEY_CURRENT_USER\Software\Ubisoft\Beyond Good & Evil

and if i remember correctly

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\GOGBEYONDGOODANDEVIL

The second one is where i created the disablealttab field.

avatar
kaileeena: Here is the reply for any is interested in removing the alt-tab disable:

Please go to the game's directory (default: C:\GOG Games\Beyond Good and Evil), Open the Notepad and enter:
sdbinst -u gog_beyond_good_and_evil.sdb

Save the file as remove.bat in the game's folder, right-click on it and select to "Run as administrator".
Nice
avatar
squid830: Just to ensure I haven't gone totally mad, are you @thebream also using Windows 7 like @kaileeena, or are you on WinXP?
avatar
thebream: Sorry I havent been active enough to reply earlier. Things have been a bit hectic for me in the past few weeks. I'm using Windows 7 64 bit.

In regards to the registry folders, I have

HKEY_CURRENT_USER\Software\Ubisoft\Beyond Good & Evil

and if i remember correctly

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\GOGBEYONDGOODANDEVIL

The second one is where i created the disablealttab field.

avatar
kaileeena: Here is the reply for any is interested in removing the alt-tab disable:

Please go to the game's directory (default: C:\GOG Games\Beyond Good and Evil), Open the Notepad and enter:
sdbinst -u gog_beyond_good_and_evil.sdb

Save the file as remove.bat in the game's folder, right-click on it and select to "Run as administrator".
avatar
thebream: Nice
Huh. Definitely different for Windows 7 then. At least there's a solution now though...
I know it's been a while but apparently there have been some changes, perhaps GOG released an update to the game. Hopefully this post will help anybody else having this issue.

The method described above involving creating the .bat file didn't work for me, but I did find the registry entries under this location (also different than mentioned above):

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1207658746

The DISABLEALTTAB entry didn't exist, but I created it and now everything is working very nicely.

As a side note, it's not just ALT-TAB that is disabled, it is actually a number of keys. In my case I was trying to run the game with NVIDIA 3D Vision (which works wonderfully with this game btw) and the game wouldn't recognize the keyboard shortcuts to increase/decrease the 3D depth.
avatar
Herbman: I know it's been a while but apparently there have been some changes, perhaps GOG released an update to the game. Hopefully this post will help anybody else having this issue.

The method described above involving creating the .bat file didn't work for me, but I did find the registry entries under this location (also different than mentioned above):

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1207658746

The DISABLEALTTAB entry didn't exist, but I created it and now everything is working very nicely.

As a side note, it's not just ALT-TAB that is disabled, it is actually a number of keys. In my case I was trying to run the game with NVIDIA 3D Vision (which works wonderfully with this game btw) and the game wouldn't recognize the keyboard shortcuts to increase/decrease the 3D depth.
I did this, and I was able to alt-tab, but when I return to the game, now the window border is overlayed as shown in the screenshot, but flickering madly -- anyone else have that problem?
Attachments:
No soultion worked for me.
Also, the thing is not only about alt-tab, making screenshots is not allowed. I thaught it was an issue with Bandicam, but it appears Print Screen is also disabled.
So I've tried playing the Steam version of this game:- Alt+tabbing makes ALL of the text in the game (UI, subtitles, menu option... EVERYTHING) disappear. So if GOG flat-out disabled Alt+tabbing in their release of this game then it's for a bloody reason.
Is there still no solution to this?
Changing the name of the BGE.exe file enabled alt tabbing for me.