It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Love the game because it is quite like Privateer which I love. But it shows that it's still in development.

Games are saved in two ways today: autosave usually when you exit the game and in any place (just not in the middle of specific sub-stories, like investigating a cargo ship) you can make a manual save during each step of the main story line. It's this last type of save where you can save as often as you want but only over the older save unless you progress the main story. You always get dumped into the system you saved in as if you warped in so don't expect to show up in the station if you saved there.

My story. I played about 15+ hours and was at the third step of the story (war planning on a planet). I decided to forgo the main story line and max out my ship. Only 3 systems are accessible at this time but there is just enough play to be entertaining. Then I had to go and logged out (saving manually, then the autosave when logging out). I came back later and somehow every saved game was corrupted. Huh? I tried every saved game of the third step of the story line and it hung on the "initializing game" (in Spanish) screen.

OK, I liked the game enough to try again but this time I wrote a quick batch file to save all games to another location, just in case. I got about another 6-7 hours into the game and on the second step of the main story (investigate the Genesis). I did a load of a game and suddenly both research items I had ("unknown toxin" and "autoimmune cure") were gone! I was still healing some low health crew members so I hadn't healed the two crew members with the autoimmune disease. Neither my manual save nor any of the autosaves brought those things back.

OK, I tried again loading a manual saved game from the first step of the main story (lost about 5 hours). Unfortunately I was in the middle of the autoimmune sub-story where I had Rose, had some crate of mold (I think) but I hadn't gone back to the planet and the lab to make it into an autoimmune cure. Right now I have a greyed out mold (I think) crate in my inventory, I have Rose but no location on any planet (there is one per system and only three systems available) to process the mold (I think). I am frustrated at the saves being screwed up and without a decent save, all the time put in is useless. Guess I'll have to put the game on the shelf until it's more mature.

A minor nit. There is in option to open a crate (a kind of treasure chest) or place it in storage. I though it would go to my stash unopened, instead it disappeared into the middle of the page and I cannot find it. Where do crates go when storage is selected?

I hope it continues in development fixing these bugs as it has potential but is hard to play open-ended like Privateer because you can't reliably save any progress.

Sci-fi game resume:
- Played most Wing Commander games
- Played hundreds of hours in Privateer
- Was the owner of the Boston Freelancer server for four years (after this I still love Freelancer but hate PvP!)
Sorry for the issues Erendil1, could you send us a bug report to take a look into your saved game?

Sorry, I decided to try again because I noticed an update and thus I threw out the old saved games before I saw the dev's reply. I have already spent about 20 hours into a new game, already have the two cures but haven't investigated the Genesis yet. No problems yet but if I have a problem with a saved game I will accompany it with a bug report.