It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Battlezone 98 Redux will not start. After starting from the launcher it simply vanishes.

TS-steps done:
Verified/repaired the installation, tried completely removing and reinstalling.
Tried launching in windowed mode and with various lower resolution options.
Tried to change the renderer in Ogre.cfg to dx9/11/opengl. All result in the same issue.
Switched off every possible image modification setting in AMD Adrenalin Software Suite (freesync, image sharpening, chill, etc).
Removed all Microsoft Visual C++ packages from the system and reinstalled them cleanly.
Disabled Galaxy overlay.

Launched the game with /console flag for output - attached to this case.

Windows Version: 10.0.19041 Build 19041
GPU drivers: 21.2.2 (latest)
GPU: AMD RX 6800 XT

Let me know if any additional information is required to debug this case as I'm completely out of ideas.
It used to work fine on Nvidia GPUs last year, but ever since I've moved over to the 6800 XT, it will not start.
I also contacted Rebellion support directly and they are out of ideas at this point as well, though they did confirm that the game is supposed to work just fine on the latest RDNA2 GPUs.
The only other option I have left on the table is to reinstall Windows10 from scratch but I don't think that it will fix the issue nor is a proper approach for getting this resolved.

Any ideas? Feedback is much appreciated.

UPDATE:
Purchased the Steam version of Battlezone 98 Redux and that one works right out of the box, no issues.
Created a support ticket to GOG for further investigation.

UPDATE2:
Last version from GOG which the game launches fine with is 2.0.155 t2.
Steam version which also launches fine is 2.2.301.
GOG is investigating the matter and hopefully they can patch their launcher up - seems like a really edge-case with the new RDNA2 GPUs - though cannot confirm it as none of my friends actually have AMD GPUs to test with.
Attachments:
Post edited March 11, 2021 by Kallestofeles
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Kallestofeles: Battlezone 98 Redux will not start. After starting from the launcher it simply vanishes.

TS-steps done:
Verified/repaired the installation, tried completely removing and reinstalling.
Tried launching in windowed mode and with various lower resolution options.
Tried to change the renderer in Ogre.cfg to dx9/11/opengl. All result in the same issue.
Switched off every possible image modification setting in AMD Adrenalin Software Suite (freesync, image sharpening, chill, etc).
Removed all Microsoft Visual C++ packages from the system and reinstalled them cleanly.
Disabled Galaxy overlay.

Launched the game with /console flag for output - attached to this case.

Windows Version: 10.0.19041 Build 19041
GPU drivers: 21.2.2 (latest)
GPU: AMD RX 6800 XT

Let me know if any additional information is required to debug this case as I'm completely out of ideas.
It used to work fine on Nvidia GPUs last year, but ever since I've moved over to the 6800 XT, it will not start.
I also contacted Rebellion support directly and they are out of ideas at this point as well, though they did confirm that the game is supposed to work just fine on the latest RDNA2 GPUs.
The only other option I have left on the table is to reinstall Windows10 from scratch but I don't think that it will fix the issue nor is a proper approach for getting this resolved.

Any ideas? Feedback is much appreciated.

UPDATE:
Purchased the Steam version of Battlezone 98 Redux and that one works right out of the box, no issues.
Created a support ticket to GOG for further investigation.

UPDATE2:
Last version from GOG which the game launches fine with is 2.0.155 t2.
Steam version which also launches fine is 2.2.301.
GOG is investigating the matter and hopefully they can patch their launcher up - seems like a really edge-case with the new RDNA2 GPUs - though cannot confirm it as none of my friends actually have AMD GPUs to test with.
lol I know this is a bit old but I don't frequent the GOG forums much.
Do you know what rendering engine you had enabled when you took that console screencap?
I have an odd suggestion: In the root directory of the game, either rename move or delete "RenderSystem_GL.dll" and make sure you're attempting to load in dx9 mode (-renderer=dx9).
It will complain in the console/BZLogger.txt but it's merely complaining.

Recently, I assume what must have been a GPU driver update on my R9 380 broke the game, at least the GOG version. I am forgetting now but I can say that I also deleted the dll in the Steam version. The OpenGL renderer runs like crap anyway!
BTW if you try dx11 and it looks "normal", it's probably more efficient to use it. I get strange issues with specular maps so I personally do not.

- Scott