It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi Everyone,

So i've been having difficulty getting battle realms to run on windows 10 for a few months now, i have searched around on the net, called up microsoft tech, searched a couple of the threads on this forum that were relevant to my issue (Especially the one about disabling gsync in the nvidia control panel which i can't find on my computer though i did download an nvidia physx program from the official website) and so far haven't had any luck. The issue i'm having with battle realms is when i start the game from the desktop icon and then press play it doesn't progress past the main startup screen nor does the battle realms logo show up as it does when loading the game. I have changed the compatibility settings to different versions both with administrator priviliges and without and disabled display scaling on high dpi settings, i reinstalled battle realms and again so far no luck. I am not sure what else i can even do at this point, any help would be most appreciated. Note: If any further info pertaining to this issue is needed i will be happy to provide it if asked.

Sincerely,
AngelsFortitude
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
AngelsFortitude: Hi Everyone,

So i've been having difficulty getting battle realms to run on windows 10 for a few months now, i have searched around on the net, called up microsoft tech, searched a couple of the threads on this forum that were relevant to my issue (Especially the one about disabling gsync in the nvidia control panel which i can't find on my computer though i did download an nvidia physx program from the official website) and so far haven't had any luck. The issue i'm having with battle realms is when i start the game from the desktop icon and then press play it doesn't progress past the main startup screen nor does the battle realms logo show up as it does when loading the game. I have changed the compatibility settings to different versions both with administrator priviliges and without and disabled display scaling on high dpi settings, i reinstalled battle realms and again so far no luck. I am not sure what else i can even do at this point, any help would be most appreciated. Note: If any further info pertaining to this issue is needed i will be happy to provide it if asked.

Sincerely,
AngelsFortitude
I believe PhysX doesn't have to do anything with this. The nVIDIA Control Panel does, and it always comes with the right video-drivers.

As I've already said, 99% of the problems come not from windows itself, but from the PC hardware/software.

What copies of BR have you tried? Is it on GOG version? Have you tried the original BRWOTW release? (There's a slight difference between OR and GOG release)

I'm guessing it must be either some of the background programs/processes or the videocard causing troubles. The videocard and display settings are 90% of all the problems. Try to set the resolution in battlerealms.ini to 800x600 (with disabed scaling) and see if it launches.

If we don't solve this problem, I guess you'll have to try running BR in the window mode (1024x768 max res), it needs a special program to do properly. But for now, we'll leave this, until we clarify the situation.
avatar
AngelsFortitude: Hi Everyone,

So i've been having difficulty getting battle realms to run on windows 10 for a few months now, i have searched around on the net, called up microsoft tech, searched a couple of the threads on this forum that were relevant to my issue (Especially the one about disabling gsync in the nvidia control panel which i can't find on my computer though i did download an nvidia physx program from the official website) and so far haven't had any luck. The issue i'm having with battle realms is when i start the game from the desktop icon and then press play it doesn't progress past the main startup screen nor does the battle realms logo show up as it does when loading the game. I have changed the compatibility settings to different versions both with administrator priviliges and without and disabled display scaling on high dpi settings, i reinstalled battle realms and again so far no luck. I am not sure what else i can even do at this point, any help would be most appreciated. Note: If any further info pertaining to this issue is needed i will be happy to provide it if asked.

Sincerely,
AngelsFortitude
avatar
BRJoker: I believe PhysX doesn't have to do anything with this. The nVIDIA Control Panel does, and it always comes with the right video-drivers.

As I've already said, 99% of the problems come not from windows itself, but from the PC hardware/software.

What copies of BR have you tried? Is it on GOG version? Have you tried the original BRWOTW release? (There's a slight difference between OR and GOG release)

I'm guessing it must be either some of the background programs/processes or the videocard causing troubles. The videocard and display settings are 90% of all the problems. Try to set the resolution in battlerealms.ini to 800x600 (with disabed scaling) and see if it launches.

If we don't solve this problem, I guess you'll have to try running BR in the window mode (1024x768 max res), it needs a special program to do properly. But for now, we'll leave this, until we clarify the situation.
Even though this is a very late reply, im gonna post this update here. I eventually found out a long while back that it was due to Microsoft disabling the DRM that came with Battle Realms called SafeDisc 2 which did not work on Windows 10 for security reasons. I have since downgraded from Windows 10 for various reasons. Thank you for trying to help.
avatar
BRJoker: I believe PhysX doesn't have to do anything with this. The nVIDIA Control Panel does, and it always comes with the right video-drivers.

As I've already said, 99% of the problems come not from windows itself, but from the PC hardware/software.

What copies of BR have you tried? Is it on GOG version? Have you tried the original BRWOTW release? (There's a slight difference between OR and GOG release)

I'm guessing it must be either some of the background programs/processes or the videocard causing troubles. The videocard and display settings are 90% of all the problems. Try to set the resolution in battlerealms.ini to 800x600 (with disabed scaling) and see if it launches.

If we don't solve this problem, I guess you'll have to try running BR in the window mode (1024x768 max res), it needs a special program to do properly. But for now, we'll leave this, until we clarify the situation.
avatar
AngelsFortitude: Even though this is a very late reply, im gonna post this update here. I eventually found out a long while back that it was due to Microsoft disabling the DRM that came with Battle Realms called SafeDisc 2 which did not work on Windows 10 for security reasons. I have since downgraded from Windows 10 for various reasons. Thank you for trying to help.
This is really weird since I know people who run it on Windows 10 just fine... I'll make sure it's reported to the current devs (the BR relaunch for Steam/Galaxy).
To add, after such a long time:

Battle Realms works on Windows 10 by default (tried and tested by lots of people), so it's not because of SafeDisc 2 or anything of that sort.

In one of the topics on this forum there's this:

" It works in Windows 10 if you disable any secondary monitors and change the bitdepth to 32. Otherwise it will complain about display modes.

I'm running on Win10 with a 390x" (c)
avatar
BRJoker: To add, after such a long time:

Battle Realms works on Windows 10 by default (tried and tested by lots of people), so it's not because of SafeDisc 2 or anything of that sort.

In one of the topics on this forum there's this:

" It works in Windows 10 if you disable any secondary monitors and change the bitdepth to 32. Otherwise it will complain about display modes.

I'm running on Win10 with a 390x" (c)
Can say this is correct . Just tried this . Before starting this game you have to open Battle_Realms.ini and change three lines :

[VideoState]
Width =1024 <== by the way you can pick your resolution here
Height =768
Depth =32 <== from 16 to 32
Fullscreen =0 <== from 1 to 0
HardwareTL =1 <== from 0 to 1

also you have to add Winxp SP2 compatibility with Admin rights , and after that it booted the game just fine
I cannot reply for some reason .-. btw I am using windows 10 and did everything hfric said, even swapping Fullscreen to 1 and HardwareTL to 0 (I also set all the compatibilities).
I have only 1 monitor but the problem persists, any idea?
avatar
Battamich: I cannot reply for some reason .-. btw I am using windows 10 and did everything hfric said, even swapping Fullscreen to 1 and HardwareTL to 0 (I also set all the compatibilities).
I have only 1 monitor but the problem persists, any idea?
'Ello. :)

What hfric suggested wouldn't help you at all.

It barely helps anyone. BR works fine without setting any compatibilities, entering 16bit modes etc.

You can only change the resolution/bitdepth via ini if you have 4:3 or 5:4 displays.

HardwareTL or Fullscreen options don't work. Changing them makes no sense.

Fixing all this stuff is bothersome as BR is capricious about new hardware (not windows and whatever you're told by other people).

Navigate here and good luck!
Post edited January 28, 2018 by BRJoker