It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Still bugged? Noooooo ;-(
At least you can now play the game properly (before it ran so sluggish in default 3D mode that I couldn't do anything, audio in the cutscenes didn't work etc.), but would be cool if those soundtrack issues would be fixed as well.
Post edited April 18, 2013 by spillblood
The difficulty of some sections is so high that you won't notice the music issue, because the playback resets every time you reload a save.

Meanwhile, I scrolled down through the list of my games and found that Gangsters could use some fixing. Investigators check out the thread there.
Post edited April 18, 2013 by grviper
Did the music loop before or does it loop in the disc version? Settlers 3 (also made by Blue Byte) has an issue with the music playing once then stopping. AFAIK its caused by the way the music is queued being no longer present in new versions of Windows, it happens on the disc version too. I'm wondering if it's a similar issue.


Also, does Battle Isle: The Andosia War still need patching as per this thread:

[url=http://www.gog.com/forum/battle_isle/battle_isle_4_will_it_ever_be_patched_by_gog_to_latest_version_208 ]http://www.gog.com/forum/battle_isle/battle_isle_4_will_it_ever_be_patched_by_gog_to_latest_version_208 [/url]
music does loop in the cd version. will also check the old GOG builds whether this is a new issue or whether it had been there but nobody noticed.
avatar
Alfie3000: . I'm wondering if it's a similar issue.
Yes, it is. We are working on fixing it, but it's a tad more problematic and I don't have any ETA to give. Unfortunately.
Another bug with the music: The in-game controls for music volume at the bottom of the screen don't work. You aren't able to change volume or disable the music.
Post edited April 20, 2013 by spillblood
I've been playing a bit with the new build and while it seems it is an improvement I still have some issues.

I'm going to make a little recap of my experience here:

DirectX mode:
Jerky mouse movement – The mouse doesn't response correctly ignoring any movement for several seconds, the only way to fix this is changing the priority of the incubation process in the task manager to "Above normal" or "normal".

No music in game (menus and in mission) and no sound in cutscenes – If I use alttab I can listen the music and the cutscene audio while the game is in the background. As soon I come back to the game the sound stops. When I'm playing a mission the music suddenly starts playings but for less than a second.

3Dfx mode:
Jerky mouse movement – It's more smooth than the mouse in DX mode, but not as good as if you change the priority of the process in task manager.

Music (menus) – It plays correctly for a while and then it stops and resume repeatedly.

Sound in cutscenes – It doesn't play smoothly, also it seems that the
cutscenes itself plays a bit slow so the sound gets out of synch. (The sound ends earlier than the action in the cutscene)

In the end it seems that 3Dfx mode works a bit better than DirectX and let me play the game.

Just in case, some months ago I had a conversation with gog support about incubation, maybe it can be useful.

P.D: Sorry for my English, I know it's not the best :S
set win95 compatibility on the executables, that should fix the mouse issues.
Well I've tried your suggestion and it seems it worked like a charm!
Even sound works flawlessly, at least for a quick test.

Many thanks Voodoo!
This is a repost from another thread that was mistakenly marked as "solved"

Today I also ran into this problem, but with a twist.

besides the general problems of starting up this game, wich are seemingly random.
I hear no sound in the cutscene "Get out of here".
however
When starting a new campaign, the cutscene in the spaceship works perfectly well with sound and everything.
(this would back up the claims that it has something to do with savegames with my poor knowledge of computers)

I've went out of my way to make sure there isn't an audio cd in my cd-Rom drive like Pantzu said in the apparent Solution post, but this did not work at all.

I'm on windows 8.1 if that matters