It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Greetings :)

I've bought the Battle-Isle pack and installed it (New Installer)
After that I started Incubation and choose to play a "New Game".
Well...I noticed, that the Music during the "Intro" ist not the right one (because you can hear no talking etc.)
Same goes for the "Cutscenes" (there it also plays a random Song and not the proper ones with the Speeches).

Has anyone else encountered this problem?
How could I fix it?

(btw: I'm sure I know what I'm talking about, because I played Incubation back in the 90's ;)
Post edited March 17, 2011 by turrican
This question / problem has been solved by santheoclesimage
I had the same problem, even with the new build this seems to be working somewhat erratically. Strangely enough, a workaround for me is playing with my DVD-drive open. I don't even know why I tried that, but all audio tracks play normally then. Alternatively, you could insert a CD containing audio tracks, that's supposed to work too.
If you haven't got a physical drive, emulating one should work too.
I had a Audio-CD in my DVD-Drive and after I removed the CD and started the game, everything was fine.
Indeed a strange thing, but at least everything's working as it was supposed to.

Thank you for your help
I have the same problem with the erratic music, and no voice-overs during the cutscenes. I'm playing on a netbook with no DVD-drive, so I am running with Daemontools to emulate a DVD-drive, unmounted. It still doesn't play voice-overs during cinematics though. Any ideas on how to solve this?
Have you tried to mount an Audio CD Image with Demon Tools?
You should get music with this.
If you got Music, but no voices in the Meetings with Rutherford (or not the correct ones) try to eject it in DemonTools (not unmount), worked for me.
The eject work for me Too on my eee slate ... An now I can enjoy Sounds :-)
Post edited May 14, 2011 by RogueChristian