It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Game crashes every time at the end of Iron Outpost for me. Right when I enter the room with all the guys at the end. I'm not sure if a fight is about to start when it crashes or what. Bought 3 games on GOG for first time ever and can't get past the first dungeon in the first game because of this crash. I play on Steam and constantly and have 0 issues with any other games. I see no post from anyone else with this same issue. I can't even send the GOG error report because it disappears when I'm forced to close out of the game. I'm going test a couple random things such as rolling back my newly updated video card drivers. I'm running AMD R9 200 series video card btw. If anyone has experienced similiar issues and has figured out a fix please let me know. I'll update accordingly if I find a fix. Thanks!


So I found there was a new driver for AMD and updated instead of rolled it back. Went back into the game and it went to the cutscene no problem and I was able to continue to play. All fixed, right? Well not so much, while doing Junktown for the first time when the end of the dungeon rolled around and it was about to cut to another cutscene - BOOM crash again. I'm not sure why cutscenes won't load but I'm going to go mess with some settings and try again. I'm almost at my limit of crashes before I kick the game to the curb. Which sucks because I am enjoying the game, besides the crashing of course. Thanks for the help of testing it out on an AMD card DF1871.


I tried adjusting some settings and still have the same problem. Right after the boss battle in Junktown, when it switched to a cutscene I presume, the game crashed again. I'm going to just pass on playing it for awhile and maybe come back if I see a way to fix it on here. Good luck, it's a fun game - I wish I could play it.
Post edited February 19, 2018 by MasterZar
No posts in this topic were marked as the solution yet. If you can help, add your reply
I started a game a few days ago and just finished the iron outpost yesterday twice (normal+heroic).
For testing i secured a save before the final fight and tried it on my laptop and the PC+Laptop of a friend.

It worked without problem. They all have a amd-chip with a envida-card and i use WIN 7, my friend use linux for his PC and WIN 10 for the laptop.

I can only guess but damaged savegames, incomplete installation or a problem with the backround software(a cutscene should be played after entering the room, i had similar problems quite often because some player or other adds where installed together with the game and without rights they where blocked from being started or stopped while trying to phone home ) come into my mind.
Post edited February 18, 2018 by DF1871
How should I proceed to find the informations related to BSOD ? Just one (for now) and I ignore too : if there is somewhere a crash report ?
Because for once, yesterday the game (Build 23731 under Windows 10 x64 v1607 with Nvidia driver v387.92) has crash. At the moment, I was inside the Crimson Garden or about to be resurrected.

What about the flickering ? Well that's true my laptop has sometimes this trouble. In fact, I can see it when I want to change the group (yes each times).

It's normal to be block at level 30 ? I'm just wonder.

PS : I'm aware about the new driver v391.01 but I will try to update later.
What about a new build ? They plan to correct the level ? Let's say I won't be happy to catch up the difference (for the last character Alumon, Red Monika and the worst is Knolan)
What about the GOG Galaxy ? At the beginning, it was the Build 23172 and I was deceive because it didn't show me any update (game gift). Then I had choose to proceed manually (patch 23172 ===> 23288 ===> 23731). That's true, from my point of view yes I will call it a missing feature.
Post edited March 03, 2018 by Sierona
Gonna bump this thread, I'm having the same issue - the game crashes as soon as I approach the group of bandits in the last room of the Iron Outpost. Windows 7, GeForce 960M.
Another bump: I've managed to get past the Outpost by removing the cutscene file - however, I've ran into the same error in Junktown. I'm using latest nVidia drivers and K-Lite codec pack.