It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Well... I was getting achievements just fine. This is my first playthrough so no ironman and just the basic difficulty... but I was getting achievements fine. Then I killed 2 different goblin overseers with a crossbow and didn't get that achievement. Thought maybe it was just bugged. Then I defeated the greenskin invasion. No achievement. Retired through the greenskin invasion dialog. No achievement of any kind. Not sure what's going on here... anyone else have achievement troubles?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Just a note... I reloaded a save from before. Played through a fight again and got the defeated greenskins dialog again. This time did not retire and the next dialog I got after a bit was the one for ambition complete for the greenskin invasion so.... dunno. Still no achievement. Now the final fight I got in was a hybrid fight with 4 armies only 1 of which were greenskins. Maybe that messed it up? I could reload again and try to find another fight that is just greenskins. I'll let you know.

Though that still doesn't explain killing 2 different Goblin Overseers with crossbows and not getting that one...
Post edited October 06, 2018 by Halfhoot
Another note... Just found and killed a Goblin Shaman. No Achievement. So achievements on this playthrough are completely broken. I'm going to start a new veteran playthrough and get to day 10. See if that works.